about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorMikael Brockman <mikael@brockman.se>2017-07-10 17:10:45 +0300
committerDaniel Brockman <daniel@brockman.se>2017-07-12 16:37:50 +0300
commit442d04d1dde24a628fd2427926724219a5c4dc6b (patch)
treecae2140cfcdf7878cbf94f670a91ac2b72a8d40e /pkgs/development
parent6dcba74af6aa44ef662499070a6c36c8a7c56a3d (diff)
downloadnixlib-442d04d1dde24a628fd2427926724219a5c4dc6b.tar
nixlib-442d04d1dde24a628fd2427926724219a5c4dc6b.tar.gz
nixlib-442d04d1dde24a628fd2427926724219a5c4dc6b.tar.bz2
nixlib-442d04d1dde24a628fd2427926724219a5c4dc6b.tar.lz
nixlib-442d04d1dde24a628fd2427926724219a5c4dc6b.tar.xz
nixlib-442d04d1dde24a628fd2427926724219a5c4dc6b.tar.zst
nixlib-442d04d1dde24a628fd2427926724219a5c4dc6b.zip
solc: make sure to use dynamic Boost libs
For some reason the default options enable static Boost libs on Darwin,
but that doesn't work for us.
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/compilers/solc/default.nix3
1 files changed, 3 insertions, 0 deletions
diff --git a/pkgs/development/compilers/solc/default.nix b/pkgs/development/compilers/solc/default.nix
index c2b1413b4826..24bd7d4f5177 100644
--- a/pkgs/development/compilers/solc/default.nix
+++ b/pkgs/development/compilers/solc/default.nix
@@ -27,6 +27,9 @@ stdenv.mkDerivation {
       --replace '${jsoncppURL}' ${jsoncpp}
     substituteInPlace cmake/EthCompilerSettings.cmake \
       --replace 'add_compile_options(-Werror)' ""
+    substituteInPlace cmake/EthDependencies.cmake \
+      --replace 'set(Boost_USE_STATIC_LIBS ON)'   \
+                'set(Boost_USE_STATIC_LIBS OFF)'
   '';
 
   buildInputs = [ boost cmake ];