about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2010-03-18 15:47:29 +0000
committerLudovic Courtès <ludo@gnu.org>2010-03-18 15:47:29 +0000
commit42ef635518bdb4c88e6544db4556da60ea132e2b (patch)
treedad698ebe4650f2d2650407d4156ff8882f7afc1 /pkgs/development
parentb4b3cb2d013dfc1073da9036db26a77825063f7a (diff)
downloadnixlib-42ef635518bdb4c88e6544db4556da60ea132e2b.tar
nixlib-42ef635518bdb4c88e6544db4556da60ea132e2b.tar.gz
nixlib-42ef635518bdb4c88e6544db4556da60ea132e2b.tar.bz2
nixlib-42ef635518bdb4c88e6544db4556da60ea132e2b.tar.lz
nixlib-42ef635518bdb4c88e6544db4556da60ea132e2b.tar.xz
nixlib-42ef635518bdb4c88e6544db4556da60ea132e2b.tar.zst
nixlib-42ef635518bdb4c88e6544db4556da60ea132e2b.zip
DejaGNU: Fix the default target found by `runtest'.
svn path=/nixpkgs/trunk/; revision=20744
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/tools/misc/dejagnu/default.nix2
-rw-r--r--pkgs/development/tools/misc/dejagnu/wrapped-runtest-program-name.patch15
2 files changed, 17 insertions, 0 deletions
diff --git a/pkgs/development/tools/misc/dejagnu/default.nix b/pkgs/development/tools/misc/dejagnu/default.nix
index 7ac79ecb12a1..fec825627eaf 100644
--- a/pkgs/development/tools/misc/dejagnu/default.nix
+++ b/pkgs/development/tools/misc/dejagnu/default.nix
@@ -8,6 +8,8 @@ stdenv.mkDerivation rec {
     sha256 = "13841q6pfwd9d1sdw48yxdyb4xhiccii0mb0ilql627v43pyvyyh";
   };
 
+  patches = [ ./wrapped-runtest-program-name.patch ];
+
   buildInputs = [ expect makeWrapper ];
 
   # FIXME: Enable when the "spawn id" problem is fixed.
diff --git a/pkgs/development/tools/misc/dejagnu/wrapped-runtest-program-name.patch b/pkgs/development/tools/misc/dejagnu/wrapped-runtest-program-name.patch
new file mode 100644
index 000000000000..d745bc65cbb2
--- /dev/null
+++ b/pkgs/development/tools/misc/dejagnu/wrapped-runtest-program-name.patch
@@ -0,0 +1,15 @@
+This patch gives `runtest' a `$0' that contains `runtest' instead
+of `.runtest-wrapped'.  This is required because `runtest' checks
+what `$0' looks like to determine the target.
+
+--- dejagnu-1.4.4/runtest	2003-08-17 03:27:59.000000000 +0200
++++ dejagnu-1.4.4/runtest	2010-03-18 15:57:58.000000000 +0100
+@@ -10,6 +10,7 @@
+ # Get the execution path to this script and the current directory.
+ #
+ mypath=${0-.}
++mypath="`echo $mypath | sed -'es|\.runtest-wrapped|runtest|g'`"
+ if expr ${mypath} : '.*/.*' > /dev/null
+ then
+     :
+