about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorDomen Kožar <domen@dev.si>2016-06-16 11:49:19 +0100
committerDomen Kožar <domen@dev.si>2016-06-16 11:49:19 +0100
commit3ea80681813553bae50d5c411869f94d2ca29373 (patch)
tree84a2da801ca54fee5727a131caeafac1a1dffc48 /pkgs/development
parent5b7c6a11b5d50b8f28f74da828eda07bef806fa2 (diff)
downloadnixlib-3ea80681813553bae50d5c411869f94d2ca29373.tar
nixlib-3ea80681813553bae50d5c411869f94d2ca29373.tar.gz
nixlib-3ea80681813553bae50d5c411869f94d2ca29373.tar.bz2
nixlib-3ea80681813553bae50d5c411869f94d2ca29373.tar.lz
nixlib-3ea80681813553bae50d5c411869f94d2ca29373.tar.xz
nixlib-3ea80681813553bae50d5c411869f94d2ca29373.tar.zst
nixlib-3ea80681813553bae50d5c411869f94d2ca29373.zip
buildPythonPackage: be able to disable package conflict check
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/python-modules/generic/default.nix5
1 files changed, 4 insertions, 1 deletions
diff --git a/pkgs/development/python-modules/generic/default.nix b/pkgs/development/python-modules/generic/default.nix
index 7221bac320c9..38d74e082445 100644
--- a/pkgs/development/python-modules/generic/default.nix
+++ b/pkgs/development/python-modules/generic/default.nix
@@ -42,6 +42,9 @@
 # Additional flags to pass to "pip install".
 , installFlags ? []
 
+# Raise an error if two packages are installed with the same name
+, catchConflicts ? true
+
 , format ? "setup"
 
 , ... } @ attrs:
@@ -141,7 +144,7 @@ python.stdenv.mkDerivation (builtins.removeAttrs attrs ["disabled" "doCheck"] //
 
   postFixup = attrs.postFixup or ''
     wrapPythonPrograms
-
+  '' + lib.optionalString catchConflicts ''
     # check if we have two packages with the same name in closure and fail
     # this shouldn't happen, something went wrong with dependencies specs
     ${python.interpreter} ${./catch_conflicts.py}