about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorPeter Simons <simons@cryp.to>2015-07-24 16:56:46 +0200
committerPeter Simons <simons@cryp.to>2015-07-24 16:56:46 +0200
commit3d6bd6a1facff3993d1b581dfcf9ee2b6a751642 (patch)
tree74b5c9fb1419eb0eb64548f0584d02e2ea33c47f /pkgs/development
parentc399f94bb3bfad7fab7760d4842b38c9642541b5 (diff)
downloadnixlib-3d6bd6a1facff3993d1b581dfcf9ee2b6a751642.tar
nixlib-3d6bd6a1facff3993d1b581dfcf9ee2b6a751642.tar.gz
nixlib-3d6bd6a1facff3993d1b581dfcf9ee2b6a751642.tar.bz2
nixlib-3d6bd6a1facff3993d1b581dfcf9ee2b6a751642.tar.lz
nixlib-3d6bd6a1facff3993d1b581dfcf9ee2b6a751642.tar.xz
nixlib-3d6bd6a1facff3993d1b581dfcf9ee2b6a751642.tar.zst
nixlib-3d6bd6a1facff3993d1b581dfcf9ee2b6a751642.zip
gfortran: disable parallel building to avoid weird build failures
More details are at https://github.com/NixOS/nixpkgs/commit/784025c7475610fb2fe8e28044d9d50bec1d93d1#commitcomment-12328357.
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/compilers/gcc/4.9/default.nix5
1 files changed, 4 insertions, 1 deletions
diff --git a/pkgs/development/compilers/gcc/4.9/default.nix b/pkgs/development/compilers/gcc/4.9/default.nix
index 9069387762fd..cf67d880a2cf 100644
--- a/pkgs/development/compilers/gcc/4.9/default.nix
+++ b/pkgs/development/compilers/gcc/4.9/default.nix
@@ -61,7 +61,10 @@ let version = "4.9.3";
     # Whether building a cross-compiler for GNU/Hurd.
     crossGNU = cross != null && cross.config == "i586-pc-gnu";
 
-    enableParallelBuilding = true;
+    # Builds of gfortran have failed with strange errors that we cannot reproduce
+    # (http://hydra.nixos.org/build/23951123). Our best guess is that the build
+    # system has bugs that are exposed by compiling with multiple threads.
+    enableParallelBuilding = !langFortran;
 
     patches = [ ]
       ++ optional enableParallelBuilding ../parallel-bconfig.patch