about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorPeter Simons <simons@cryp.to>2019-08-10 12:58:22 +0200
committerPeter Simons <simons@cryp.to>2019-08-11 20:48:10 +0200
commit3cbe376b37f7d3ce95bb2ae4fa9115ff2f7074ed (patch)
tree731884520c27a6385d582301c65ffab5e6b6e4ec /pkgs/development
parent79a149e0517405c0174b7176faf5ae2c12b5226a (diff)
downloadnixlib-3cbe376b37f7d3ce95bb2ae4fa9115ff2f7074ed.tar
nixlib-3cbe376b37f7d3ce95bb2ae4fa9115ff2f7074ed.tar.gz
nixlib-3cbe376b37f7d3ce95bb2ae4fa9115ff2f7074ed.tar.bz2
nixlib-3cbe376b37f7d3ce95bb2ae4fa9115ff2f7074ed.tar.lz
nixlib-3cbe376b37f7d3ce95bb2ae4fa9115ff2f7074ed.tar.xz
nixlib-3cbe376b37f7d3ce95bb2ae4fa9115ff2f7074ed.tar.zst
nixlib-3cbe376b37f7d3ce95bb2ae4fa9115ff2f7074ed.zip
haskell-llvm-hs: drop obsolete version overrides
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/haskell-modules/configuration-nix.nix5
1 files changed, 1 insertions, 4 deletions
diff --git a/pkgs/development/haskell-modules/configuration-nix.nix b/pkgs/development/haskell-modules/configuration-nix.nix
index edd64bd0b30b..5c3be19ea3c1 100644
--- a/pkgs/development/haskell-modules/configuration-nix.nix
+++ b/pkgs/development/haskell-modules/configuration-nix.nix
@@ -279,10 +279,7 @@ self: super: builtins.intersectAttrs super {
       let dontCheckDarwin = if pkgs.stdenv.isDarwin
                             then dontCheck
                             else pkgs.lib.id;
-      in dontCheckDarwin (super.llvm-hs.override {
-        llvm-config = pkgs.llvm_8;
-        llvm-hs-pure = super.llvm-hs-pure_8_0_0;
-      });
+      in dontCheckDarwin (super.llvm-hs.override { llvm-config = pkgs.llvm_8; });
 
   # Needs help finding LLVM.
   spaceprobe = addBuildTool super.spaceprobe self.llvmPackages.llvm;