about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorSamuel Dionne-Riel <samuel@dionne-riel.com>2018-12-20 21:06:52 -0500
committerGitHub <noreply@github.com>2018-12-20 21:06:52 -0500
commit3c38cc80582dfa52023fef2f2259fecc32dd356b (patch)
treeac398b2f5fa46f80bc58679bf9dabda555282c68 /pkgs/development
parent7b2b5b3f47717916fb6a850d80382a9f576e0361 (diff)
parent167076877e0c7be52fceca87f9d1c3d1b37c81da (diff)
downloadnixlib-3c38cc80582dfa52023fef2f2259fecc32dd356b.tar
nixlib-3c38cc80582dfa52023fef2f2259fecc32dd356b.tar.gz
nixlib-3c38cc80582dfa52023fef2f2259fecc32dd356b.tar.bz2
nixlib-3c38cc80582dfa52023fef2f2259fecc32dd356b.tar.lz
nixlib-3c38cc80582dfa52023fef2f2259fecc32dd356b.tar.xz
nixlib-3c38cc80582dfa52023fef2f2259fecc32dd356b.tar.zst
nixlib-3c38cc80582dfa52023fef2f2259fecc32dd356b.zip
Merge pull request #51813 from samueldr/aarch64/disable-non-arm-builds-part-1
aarch64: ZHF for aarch64 (1/??)
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/compilers/chez/default.nix1
-rw-r--r--pkgs/development/interpreters/angelscript/2.22.nix1
-rw-r--r--pkgs/development/libraries/aften/default.nix2
-rw-r--r--pkgs/development/libraries/beignet/default.nix2
-rw-r--r--pkgs/development/libraries/boost/generic.nix3
-rw-r--r--pkgs/development/libraries/bootil/default.nix2
-rw-r--r--pkgs/development/libraries/gsl/gsl-1_16.nix2
-rw-r--r--pkgs/development/libraries/openbabel/default.nix10
8 files changed, 20 insertions, 3 deletions
diff --git a/pkgs/development/compilers/chez/default.nix b/pkgs/development/compilers/chez/default.nix
index 09d68084e775..5b02aed274f8 100644
--- a/pkgs/development/compilers/chez/default.nix
+++ b/pkgs/development/compilers/chez/default.nix
@@ -83,6 +83,7 @@ stdenv.mkDerivation rec {
     homepage    = https://cisco.github.io/ChezScheme/;
     license     = stdenv.lib.licenses.asl20;
     platforms   = stdenv.lib.platforms.unix;
+    badPlatforms = [ "aarch64-linux" ];
     maintainers = with stdenv.lib.maintainers; [ thoughtpolice ];
   };
 }
diff --git a/pkgs/development/interpreters/angelscript/2.22.nix b/pkgs/development/interpreters/angelscript/2.22.nix
index c9097bec5dc8..0449572da024 100644
--- a/pkgs/development/interpreters/angelscript/2.22.nix
+++ b/pkgs/development/interpreters/angelscript/2.22.nix
@@ -38,6 +38,7 @@ stdenv.mkDerivation {
     license = stdenv.lib.licenses.zlib ;
     maintainers = [stdenv.lib.maintainers.raskin];
     platforms = stdenv.lib.platforms.linux;
+    badPlatforms = [ "aarch64-linux" ];
     downloadPage = "http://www.angelcode.com/angelscript/downloads.html";
     homepage="http://www.angelcode.com/angelscript/";
   };
diff --git a/pkgs/development/libraries/aften/default.nix b/pkgs/development/libraries/aften/default.nix
index fb16c71fd195..22e91ee61d7a 100644
--- a/pkgs/development/libraries/aften/default.nix
+++ b/pkgs/development/libraries/aften/default.nix
@@ -16,6 +16,6 @@ stdenv.mkDerivation rec {
 		description = "An audio encoder which generates compressed audio streams based on ATSC A/52 specification";
 		homepage = "http://aften.sourceforge.net/";
 		license = stdenv.lib.licenses.lgpl2;
-		platforms = stdenv.lib.platforms.unix;
+		platforms = [ "i686-linux" "x86_64-linux" "x86_64-darwin" ];
 	};
 }
diff --git a/pkgs/development/libraries/beignet/default.nix b/pkgs/development/libraries/beignet/default.nix
index 02c67d7dbf8b..ba6fc7cb541b 100644
--- a/pkgs/development/libraries/beignet/default.nix
+++ b/pkgs/development/libraries/beignet/default.nix
@@ -107,5 +107,7 @@ stdenv.mkDerivation rec {
     license = licenses.lgpl21Plus;
     maintainers = with maintainers; [ artuuge zimbatm ];
     platforms = platforms.linux;
+    # Requires libdrm_intel
+    badPlatforms = [ "aarch64-linux" ];
   };
 }
diff --git a/pkgs/development/libraries/boost/generic.nix b/pkgs/development/libraries/boost/generic.nix
index c79b874ecb69..3e488acee748 100644
--- a/pkgs/development/libraries/boost/generic.nix
+++ b/pkgs/development/libraries/boost/generic.nix
@@ -111,7 +111,8 @@ stdenv.mkDerivation {
     description = "Collection of C++ libraries";
     license = stdenv.lib.licenses.boost;
 
-    platforms = (if versionOlder version "1.59" then remove "aarch64-linux" else id) (platforms.unix ++ platforms.windows);
+    platforms = (platforms.unix ++ platforms.windows);
+    badPlatforms = stdenv.lib.optional (versionOlder version "1.59") "aarch64-linux";
     maintainers = with maintainers; [ peti wkennington ];
   };
 
diff --git a/pkgs/development/libraries/bootil/default.nix b/pkgs/development/libraries/bootil/default.nix
index 0ed223832b6c..3c27281571af 100644
--- a/pkgs/development/libraries/bootil/default.nix
+++ b/pkgs/development/libraries/bootil/default.nix
@@ -10,6 +10,8 @@ stdenv.mkDerivation rec {
     license = stdenv.lib.licenses.free;
     maintainers = [ stdenv.lib.maintainers.abigailbuccaneer ];
     platforms = stdenv.lib.platforms.all;
+    # Build uses `-msse` and `-mfpmath=sse`
+    badPlatforms = [ "aarch64-linux" ];
   };
 
   src = fetchFromGitHub {
diff --git a/pkgs/development/libraries/gsl/gsl-1_16.nix b/pkgs/development/libraries/gsl/gsl-1_16.nix
index f569d9c3ea12..69fe1b0db554 100644
--- a/pkgs/development/libraries/gsl/gsl-1_16.nix
+++ b/pkgs/development/libraries/gsl/gsl-1_16.nix
@@ -36,5 +36,7 @@ stdenv.mkDerivation rec {
       extensive test suite.
     '';
     platforms = stdenv.lib.platforms.unix;
+    # Failing "eigen" tests on aarch64.
+    badPlatforms = [ "aarch64-linux" ];
   };
 }
diff --git a/pkgs/development/libraries/openbabel/default.nix b/pkgs/development/libraries/openbabel/default.nix
index bfbf6f1212fb..81754ffad4d2 100644
--- a/pkgs/development/libraries/openbabel/default.nix
+++ b/pkgs/development/libraries/openbabel/default.nix
@@ -1,4 +1,4 @@
-{stdenv, fetchurl, cmake, zlib, libxml2, eigen, python, cairo, pcre, pkgconfig }:
+{stdenv, fetchurl, fetchpatch, cmake, zlib, libxml2, eigen, python, cairo, pcre, pkgconfig }:
 
 stdenv.mkDerivation rec {
   name = "openbabel-${version}";
@@ -9,6 +9,14 @@ stdenv.mkDerivation rec {
     sha256 = "0xm7y859ivq2cp0q08mwshfxm0jq31xkyr4x8s0j6l7khf57yk2r";
   };
 
+  patches = [
+    # ARM / AArch64 fixes.
+    (fetchpatch {
+      url = https://github.com/openbabel/openbabel/commit/ee11c98a655296550710db1207b294f00e168216.patch;
+      sha256 = "0wjqjrkr4pfirzzicdvlyr591vppydk572ix28jd2sagnfnf566g";
+    })
+  ];
+
   # TODO : perl & python bindings;
   # TODO : wxGTK: I have no time to compile
   # TODO : separate lib and apps