about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorEmery Hemingway <emery@vfemail.net>2014-12-20 15:43:43 -0500
committerEmery Hemingway <emery@vfemail.net>2014-12-20 17:37:24 -0500
commit3c05529df9efc693569471c8a55d835e740b0f5a (patch)
tree8086465d53d410610b6e945bb30ca0e266a63747 /pkgs/development
parentcbe467ef9986289710ca49ab728d3bae22ba7ac4 (diff)
downloadnixlib-3c05529df9efc693569471c8a55d835e740b0f5a.tar
nixlib-3c05529df9efc693569471c8a55d835e740b0f5a.tar.gz
nixlib-3c05529df9efc693569471c8a55d835e740b0f5a.tar.bz2
nixlib-3c05529df9efc693569471c8a55d835e740b0f5a.tar.lz
nixlib-3c05529df9efc693569471c8a55d835e740b0f5a.tar.xz
nixlib-3c05529df9efc693569471c8a55d835e740b0f5a.tar.zst
nixlib-3c05529df9efc693569471c8a55d835e740b0f5a.zip
libtoxcore: bump, build DHT bootstrap daemon
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/libraries/libtoxcore/default.nix16
1 files changed, 9 insertions, 7 deletions
diff --git a/pkgs/development/libraries/libtoxcore/default.nix b/pkgs/development/libraries/libtoxcore/default.nix
index d569cf28c37c..de224f6b613b 100644
--- a/pkgs/development/libraries/libtoxcore/default.nix
+++ b/pkgs/development/libraries/libtoxcore/default.nix
@@ -1,17 +1,18 @@
-{ stdenv, fetchurl, autoconf, libtool, automake, libsodium, ncurses, libopus
+{ stdenv, fetchFromGitHub, autoconf, libtool, automake, libsodium, ncurses, libopus
 , libvpx, check, libconfig, pkgconfig }:
 
 let
   version = "f6b3e6e8fe98d2457827ac6da944e715f008a08a";
-  date = "20141203";
+  date = "20141219";
 in
 stdenv.mkDerivation rec {
-  name = "tox-core-${date}-${version}";
+  name = "tox-core-${date}-${builtins.substring 0 7 version}";
 
-  src = fetchurl {
-    url = "https://github.com/irungentoo/toxcore/tarball/${version}";
-    name = "${name}.tar.gz";
-    sha256 = "1zsx7saqs25vva3pp0bw31yqzrn40fx84w42ig6fiv723k9gpdzy";
+  src = fetchFromGitHub {
+    owner  = "irungentoo";
+    repo   = "toxcore";
+    rev    = version;
+    sha256 = "1wd817kix3zjyzzb68jz02iir3z4y5k5p40dgl7a29757yb9m608";
   };
 
   NIX_LDFLAGS = "-lgcc_s";
@@ -33,6 +34,7 @@ stdenv.mkDerivation rec {
     "--with-libsodium-headers=${libsodium}/include"
     "--with-libsodium-libs=${libsodium}/lib"
     "--enable-ntox"
+    "--enable-daemon"
   ];
 
   buildInputs = [