about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authormarkuskowa <markus.kowalewski@gmail.com>2020-02-20 23:27:59 +0100
committerGitHub <noreply@github.com>2020-02-20 23:27:59 +0100
commit39fce027b8722487adcdef8d263671325dc38afc (patch)
tree3df2aca4dc10378632eda2f3ab4240bec2c6e72b /pkgs/development
parent143a1305eb37efe92a0283171b18baa3a5b62df0 (diff)
parent78d5a13cf8fc6f19cfb7ea8f39e397ddbd031568 (diff)
downloadnixlib-39fce027b8722487adcdef8d263671325dc38afc.tar
nixlib-39fce027b8722487adcdef8d263671325dc38afc.tar.gz
nixlib-39fce027b8722487adcdef8d263671325dc38afc.tar.bz2
nixlib-39fce027b8722487adcdef8d263671325dc38afc.tar.lz
nixlib-39fce027b8722487adcdef8d263671325dc38afc.tar.xz
nixlib-39fce027b8722487adcdef8d263671325dc38afc.tar.zst
nixlib-39fce027b8722487adcdef8d263671325dc38afc.zip
Merge pull request #80641 from ikervagyok/ucx
ucx: init at 1.7.0
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/libraries/ucx/default.nix39
1 files changed, 39 insertions, 0 deletions
diff --git a/pkgs/development/libraries/ucx/default.nix b/pkgs/development/libraries/ucx/default.nix
new file mode 100644
index 000000000000..d1e3934d882c
--- /dev/null
+++ b/pkgs/development/libraries/ucx/default.nix
@@ -0,0 +1,39 @@
+{ stdenv, fetchFromGitHub, autoreconfHook, doxygen
+, numactl, rdma-core, libbfd, libiberty, perl, zlib
+}:
+
+let
+  version = "1.7.0";
+
+in stdenv.mkDerivation {
+  name = "ucx-${version}";
+
+  src = fetchFromGitHub {
+    owner = "openucx";
+    repo = "ucx";
+    rev = "v${version}";
+    sha256 = "149p8s7jrg7pbbq0hw0qm8va119bsl19q4scgk94vjqliyc1s33h";
+  };
+
+  nativeBuildInputs = [ autoreconfHook doxygen ];
+
+  buildInputs = [ numactl rdma-core libbfd libiberty perl zlib ];
+
+  configureFlags = [
+    "--with-rdmacm=${rdma-core}"
+    "--with-dc"
+    "--with-rc"
+    "--with-dm"
+    "--with-verbs=${rdma-core}"
+  ];
+
+  enableParallelBuilding = true;
+
+  meta = with stdenv.lib; {
+    description = "Unified Communication X library";
+    homepage = http://www.openucx.org;
+    license = licenses.bsd3;
+    platforms = platforms.linux;
+    maintainers = [ maintainers.markuskowa ];
+  };
+}