about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorVladimír Čunát <vcunat@gmail.com>2016-12-22 11:30:03 +0100
committerVladimír Čunát <vcunat@gmail.com>2016-12-22 11:30:39 +0100
commit39e4d93649ce8cbe5f3ad6467c545df0125fb816 (patch)
treedfed4617c2e60bea33166bf4c90991768d6772a3 /pkgs/development
parent2b883c6f564202a32169d3bf762aa8c40156c8fb (diff)
downloadnixlib-39e4d93649ce8cbe5f3ad6467c545df0125fb816.tar
nixlib-39e4d93649ce8cbe5f3ad6467c545df0125fb816.tar.gz
nixlib-39e4d93649ce8cbe5f3ad6467c545df0125fb816.tar.bz2
nixlib-39e4d93649ce8cbe5f3ad6467c545df0125fb816.tar.lz
nixlib-39e4d93649ce8cbe5f3ad6467c545df0125fb816.tar.xz
nixlib-39e4d93649ce8cbe5f3ad6467c545df0125fb816.tar.zst
nixlib-39e4d93649ce8cbe5f3ad6467c545df0125fb816.zip
libuv: disable tests broken on Hydra
They were broken by nix starting to use user namespaces.
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/libraries/libuv/default.nix14
1 files changed, 9 insertions, 5 deletions
diff --git a/pkgs/development/libraries/libuv/default.nix b/pkgs/development/libraries/libuv/default.nix
index db77a6fefc3a..f9e7cf389bbb 100644
--- a/pkgs/development/libraries/libuv/default.nix
+++ b/pkgs/development/libraries/libuv/default.nix
@@ -1,5 +1,4 @@
 { stdenv, lib, fetchFromGitHub, autoconf, automake, libtool, pkgconfig
-
 , ApplicationServices, CoreServices }:
 
 stdenv.mkDerivation rec {
@@ -13,10 +12,15 @@ stdenv.mkDerivation rec {
     sha256 = "0gna53fgsjjs38kv1g20xfaalv0fk3xncb6abga3saswrv283hx0";
   };
 
-  # these checks are probably network-dependent
-  postPatch = lib.optionalString doCheck ''
-    sed '/getnameinfo_basic/d' -i test/test-list.h
-  '';
+  postPatch = let
+    toDisable = [
+      "getnameinfo_basic" # probably network-dependent
+      "spawn_setuid_fails" "spawn_setgid_fails" "fs_chown" # user namespaces
+    ];
+    tdRegexp = lib.concatStringsSep "\\|" toDisable;
+    in lib.optionalString doCheck ''
+      sed '/${tdRegexp}/d' -i test/test-list.h
+    '';
 
   buildInputs = [ automake autoconf libtool pkgconfig ]
     ++ stdenv.lib.optionals stdenv.isDarwin [ ApplicationServices CoreServices ];