about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorzowoq <59103226+zowoq@users.noreply.github.com>2020-02-08 09:49:42 +1000
committerzowoq <59103226+zowoq@users.noreply.github.com>2020-02-08 09:49:42 +1000
commit376743d3f2728c68a6903872c74a508e7014d06a (patch)
treec70c5b844dcef5825779c6929342a1adbe33a729 /pkgs/development
parent58ce5a3f47699995c3a3aac8930a3c83aa94fb53 (diff)
downloadnixlib-376743d3f2728c68a6903872c74a508e7014d06a.tar
nixlib-376743d3f2728c68a6903872c74a508e7014d06a.tar.gz
nixlib-376743d3f2728c68a6903872c74a508e7014d06a.tar.bz2
nixlib-376743d3f2728c68a6903872c74a508e7014d06a.tar.lz
nixlib-376743d3f2728c68a6903872c74a508e7014d06a.tar.xz
nixlib-376743d3f2728c68a6903872c74a508e7014d06a.tar.zst
nixlib-376743d3f2728c68a6903872c74a508e7014d06a.zip
skopeo: 0.1.40 -> 0.1.41
https://github.com/containers/skopeo/releases/tag/v0.1.41
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/tools/skopeo/default.nix10
1 files changed, 5 insertions, 5 deletions
diff --git a/pkgs/development/tools/skopeo/default.nix b/pkgs/development/tools/skopeo/default.nix
index e283c3bd02f3..957f691d2250 100644
--- a/pkgs/development/tools/skopeo/default.nix
+++ b/pkgs/development/tools/skopeo/default.nix
@@ -1,17 +1,17 @@
 { stdenv, lib, buildGoPackage, fetchFromGitHub, runCommand
-, gpgme, libgpgerror, lvm2, btrfs-progs, pkgconfig, ostree, libselinux
+, gpgme, libgpgerror, lvm2, btrfs-progs, pkgconfig, libselinux
 , go-md2man }:
 
 with stdenv.lib;
 
 let
-  version = "0.1.40";
+  version = "0.1.41";
 
   src = fetchFromGitHub {
     rev = "v${version}";
     owner = "containers";
     repo = "skopeo";
-    sha256 = "1bagirzdzjhicn5dr691092ac3q6lhz3xngjzgqiqkxnvpz7p6cn";
+    sha256 = "0aqw17irj2wn4a8g9hzfm5z5azqq33z6r1dbg1gyn2c8qxy1vfxs";
   };
 
   defaultPolicyFile = runCommand "skopeo-default-policy.json" {} "cp ${src}/default-policy.json $out";
@@ -29,7 +29,7 @@ buildGoPackage {
   excludedPackages = "integration";
 
   nativeBuildInputs = [ pkgconfig (lib.getBin go-md2man) ];
-  buildInputs = [ gpgme ] ++ lib.optionals stdenv.isLinux [ libgpgerror lvm2 btrfs-progs ostree libselinux ];
+  buildInputs = [ gpgme ] ++ lib.optionals stdenv.isLinux [ libgpgerror lvm2 btrfs-progs libselinux ];
 
   buildFlagsArray = ''
     -ldflags=
@@ -51,7 +51,7 @@ buildGoPackage {
 
   meta = {
     description = "A command line utility for various operations on container images and image repositories";
-    homepage = https://github.com/projectatomic/skopeo;
+    homepage = "https://github.com/containers/skopeo";
     maintainers = with stdenv.lib.maintainers; [ vdemeester lewo ];
     license = stdenv.lib.licenses.asl20;
   };