about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorGürkan Gür <gurkan.gur@innogames.com>2019-08-06 16:54:14 +0200
committerGürkan Gür <gurkan.gur@innogames.com>2019-12-31 10:30:49 +0100
commit36af8d34c92924ed9ce91733640a782d239a4e19 (patch)
tree4e03eda509335e46985ebcd55c842cb0233ec7da /pkgs/development
parent66bf75415f4e7a1571d41a2fed11838eb530376b (diff)
downloadnixlib-36af8d34c92924ed9ce91733640a782d239a4e19.tar
nixlib-36af8d34c92924ed9ce91733640a782d239a4e19.tar.gz
nixlib-36af8d34c92924ed9ce91733640a782d239a4e19.tar.bz2
nixlib-36af8d34c92924ed9ce91733640a782d239a4e19.tar.lz
nixlib-36af8d34c92924ed9ce91733640a782d239a4e19.tar.xz
nixlib-36af8d34c92924ed9ce91733640a782d239a4e19.tar.zst
nixlib-36af8d34c92924ed9ce91733640a782d239a4e19.zip
django-postgresql-netfields: init at 1.2.2
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/python-modules/django-postgresql-netfields/default.nix49
1 files changed, 49 insertions, 0 deletions
diff --git a/pkgs/development/python-modules/django-postgresql-netfields/default.nix b/pkgs/development/python-modules/django-postgresql-netfields/default.nix
new file mode 100644
index 000000000000..35be6f76147c
--- /dev/null
+++ b/pkgs/development/python-modules/django-postgresql-netfields/default.nix
@@ -0,0 +1,49 @@
+{ stdenv
+, buildPythonPackage
+, django
+, netaddr
+, six
+, fetchFromGitHub
+# required for tests
+#, djangorestframework
+#, psycopg2
+#, unittest2
+}:
+
+buildPythonPackage rec {
+  version = "1.2.2";
+  pname = "django-postgresql-netfields";
+
+  src = fetchFromGitHub {
+    owner = "jimfunk";
+    repo = "${pname}";
+    rev = "v${version}";
+    sha256 = "1rrh38f3zl3jk5ijs6g75dxxvxygf4lczbgc7ahrgzf58g4a48lm";
+  };
+
+  # tests need a postgres database
+  doCheck = false;
+
+  # keeping the dependencies below as comment for reference
+  # checkPhase = ''
+    # python manage.py test
+  # '';
+
+  # buildInputs = [
+    # djangorestframework
+    # psycopg2
+    # unittest2
+  # ];
+
+  propagatedBuildInputs = [
+    django
+    netaddr
+    six
+  ];
+
+  meta = with stdenv.lib; {
+    description = "Django PostgreSQL netfields implementation";
+    homepage = https://github.com/jimfunk/django-postgresql-netfields;
+    license = licenses.bsd2;
+  };
+}