about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorProfpatsch <mail@profpatsch.de>2018-06-25 10:53:18 +0200
committerProfpatsch <mail@profpatsch.de>2018-06-25 10:53:18 +0200
commit367a7ae138b55193d4ddea60940d01f2b10a5cb0 (patch)
tree005aac91f034769b61e62f52295ca151cdac9c35 /pkgs/development
parente6bf9c8a4581f883d10fcee573d4864be08fda1b (diff)
downloadnixlib-367a7ae138b55193d4ddea60940d01f2b10a5cb0.tar
nixlib-367a7ae138b55193d4ddea60940d01f2b10a5cb0.tar.gz
nixlib-367a7ae138b55193d4ddea60940d01f2b10a5cb0.tar.bz2
nixlib-367a7ae138b55193d4ddea60940d01f2b10a5cb0.tar.lz
nixlib-367a7ae138b55193d4ddea60940d01f2b10a5cb0.tar.xz
nixlib-367a7ae138b55193d4ddea60940d01f2b10a5cb0.tar.zst
nixlib-367a7ae138b55193d4ddea60940d01f2b10a5cb0.zip
pythonPackages.rlp: revert to working 0.6.0
It is required by electrum.
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/python-modules/rlp/default.nix9
1 files changed, 4 insertions, 5 deletions
diff --git a/pkgs/development/python-modules/rlp/default.nix b/pkgs/development/python-modules/rlp/default.nix
index fd4816c3bb57..87a59cf73975 100644
--- a/pkgs/development/python-modules/rlp/default.nix
+++ b/pkgs/development/python-modules/rlp/default.nix
@@ -1,15 +1,15 @@
-{ lib, fetchPypi, buildPythonPackage, pytest, hypothesis }:
+{ lib, fetchPypi, buildPythonPackage, pytest }:
 
 buildPythonPackage rec {
   pname = "rlp";
-  version = "1.0.1";
+  version = "0.6.0";
 
   src = fetchPypi {
     inherit pname version;
-    sha256 = "492c11b18e89af42f98e96bca7671ffee4ad4cf5e69ea23b4d2221157d81b512";
+    sha256 = "0d3gx4mp8q4z369s5yk1n9c55sgfw9fidbwqxq67d6s7l45rm1w7";
   };
 
-  checkInputs = [ pytest hypothesis ];
+  checkInputs = [ pytest ];
   propagatedBuildInputs = [ ];
 
   meta = {
@@ -17,6 +17,5 @@ buildPythonPackage rec {
     homepage = "https://github.com/ethereum/pyrlp";
     license = lib.licenses.mit;
     maintainers = with lib.maintainers; [ gebner ];
-    broken = true; # Requires a chain of unpackaged dependencies.
   };
 }