about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorRobert Schütz <rschuetz17@gmail.com>2018-06-26 20:22:38 +0200
committerGitHub <noreply@github.com>2018-06-26 20:22:38 +0200
commit352995d79b9fac78c7414a8c880662892ed495cc (patch)
tree43121eb9368b74c7eb14e73e185651750fda0cbe /pkgs/development
parent9e02afcd80043f57e193bdc0f31a7745ffd2164f (diff)
parent5db01c52434e55ea95b477a204ee29cb4fb8c53a (diff)
downloadnixlib-352995d79b9fac78c7414a8c880662892ed495cc.tar
nixlib-352995d79b9fac78c7414a8c880662892ed495cc.tar.gz
nixlib-352995d79b9fac78c7414a8c880662892ed495cc.tar.bz2
nixlib-352995d79b9fac78c7414a8c880662892ed495cc.tar.lz
nixlib-352995d79b9fac78c7414a8c880662892ed495cc.tar.xz
nixlib-352995d79b9fac78c7414a8c880662892ed495cc.tar.zst
nixlib-352995d79b9fac78c7414a8c880662892ed495cc.zip
Merge pull request #42052 from makefu/pkgs/python-forecastio/init
pythonPackages.python-forecastio: init at 1.4.0
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/python-modules/python-forecastio/default.nix31
1 files changed, 31 insertions, 0 deletions
diff --git a/pkgs/development/python-modules/python-forecastio/default.nix b/pkgs/development/python-modules/python-forecastio/default.nix
new file mode 100644
index 000000000000..68f9ad16977b
--- /dev/null
+++ b/pkgs/development/python-modules/python-forecastio/default.nix
@@ -0,0 +1,31 @@
+{ buildPythonPackage, stdenv, fetchPypi
+, requests
+, nose
+, responses
+}:
+
+buildPythonPackage rec {
+  pname = "python-forecastio";
+  version = "1.4.0";
+
+  src = fetchPypi {
+    inherit pname version;
+    sha256 = "0m6lf4a46pnwm5xg9dnmwslwzrpnj6d9agw570grciivbvb1ji0l";
+
+  };
+
+  checkInputs = [ nose ];
+
+  propagatedBuildInputs = [ requests responses ];
+
+  checkPhase = ''
+    nosetests
+  '';
+
+  meta = with stdenv.lib; {
+    homepage = https://zeevgilovitz.com/python-forecast.io/;
+    description = "A thin Python Wrapper for the Dark Sky (formerly forecast.io) weather API";
+    license = licenses.bsd2;
+    maintainers = with maintainers; [ makefu ];
+  };
+}