about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authornyanloutre <paul@nyanlout.re>2019-01-29 14:45:21 +0100
committernyanloutre <paul@nyanlout.re>2019-01-30 09:58:15 +0100
commit351256a9dfd2861d41ad7951a186f58ae8f37333 (patch)
treeb3733c7d78714eb036fa924ec34fdc4307280d4e /pkgs/development
parent7993fa60b8ff96138d638ff7d1476863ddf833c6 (diff)
downloadnixlib-351256a9dfd2861d41ad7951a186f58ae8f37333.tar
nixlib-351256a9dfd2861d41ad7951a186f58ae8f37333.tar.gz
nixlib-351256a9dfd2861d41ad7951a186f58ae8f37333.tar.bz2
nixlib-351256a9dfd2861d41ad7951a186f58ae8f37333.tar.lz
nixlib-351256a9dfd2861d41ad7951a186f58ae8f37333.tar.xz
nixlib-351256a9dfd2861d41ad7951a186f58ae8f37333.tar.zst
nixlib-351256a9dfd2861d41ad7951a186f58ae8f37333.zip
pythonPackages.telethon: init at 1.5.4
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/python-modules/telethon/default.nix30
1 files changed, 30 insertions, 0 deletions
diff --git a/pkgs/development/python-modules/telethon/default.nix b/pkgs/development/python-modules/telethon/default.nix
new file mode 100644
index 000000000000..d847a4942018
--- /dev/null
+++ b/pkgs/development/python-modules/telethon/default.nix
@@ -0,0 +1,30 @@
+{ lib, buildPythonPackage, fetchPypi, async_generator, rsa, pyaes, pythonOlder }:
+
+buildPythonPackage rec {
+  pname = "telethon";
+  version = "1.5.4";
+
+  src = fetchPypi {
+    inherit version;
+    pname = "Telethon";
+    sha256 = "52cb4929bf37c98ab5f3e173325dbb3cb9c1ca3f4fe6ba87d35c43e2f98858ce";
+  };
+
+  propagatedBuildInputs = [
+    async_generator
+    rsa
+    pyaes
+  ];
+
+  # No tests available
+  doCheck = false;
+
+  disabled = pythonOlder "3.5";
+
+  meta = with lib; {
+    homepage = https://github.com/LonamiWebs/Telethon;
+    description = "Full-featured Telegram client library for Python 3";
+    license = licenses.mit;
+    maintainers = with maintainers; [ nyanloutre ];
+  };
+}