about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorDomen Kožar <domen@dev.si>2018-12-29 18:59:55 +0000
committerDomen Kožar <domen@dev.si>2018-12-29 18:59:55 +0000
commit324f018fb5f9b01f08fe8258f233eb720ad35cfe (patch)
tree5e87beb0c9100feed23cfb917bdb52424df276e1 /pkgs/development
parent6b1a429df33617bb99797bfbe00e13e5bce1e9ad (diff)
downloadnixlib-324f018fb5f9b01f08fe8258f233eb720ad35cfe.tar
nixlib-324f018fb5f9b01f08fe8258f233eb720ad35cfe.tar.gz
nixlib-324f018fb5f9b01f08fe8258f233eb720ad35cfe.tar.bz2
nixlib-324f018fb5f9b01f08fe8258f233eb720ad35cfe.tar.lz
nixlib-324f018fb5f9b01f08fe8258f233eb720ad35cfe.tar.xz
nixlib-324f018fb5f9b01f08fe8258f233eb720ad35cfe.tar.zst
nixlib-324f018fb5f9b01f08fe8258f233eb720ad35cfe.zip
add elm2nix
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/tools/elm2nix/default.nix24
1 files changed, 24 insertions, 0 deletions
diff --git a/pkgs/development/tools/elm2nix/default.nix b/pkgs/development/tools/elm2nix/default.nix
new file mode 100644
index 000000000000..2d4ebc37b0c9
--- /dev/null
+++ b/pkgs/development/tools/elm2nix/default.nix
@@ -0,0 +1,24 @@
+{ mkDerivation, aeson, ansi-wl-pprint, async, base, binary
+, bytestring, containers, data-default, directory, filepath, here
+, mtl, optparse-applicative, process, req, stdenv, text
+, transformers, unordered-containers
+}:
+mkDerivation {
+  pname = "elm2nix";
+  version = "0.1.0";
+  sha256 = "9ec1f1f694a38b466ebd03aaa1a035bbdb9bdae390be5b9a030611bcbfd91890";
+  isLibrary = true;
+  isExecutable = true;
+  libraryHaskellDepends = [
+    aeson async base binary bytestring containers data-default
+    directory filepath here mtl process req text transformers
+    unordered-containers
+  ];
+  executableHaskellDepends = [
+    ansi-wl-pprint base directory here optparse-applicative
+  ];
+  testHaskellDepends = [ base ];
+  homepage = "https://github.com/domenkozar/elm2nix#readme";
+  description = "Turn your Elm project into buildable Nix project";
+  license = stdenv.lib.licenses.bsd3;
+}