about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2022-04-02 22:04:49 +0200
committerGitHub <noreply@github.com>2022-04-02 22:04:49 +0200
commit30bdb6a5c831bd87e98d947a47a8ea16d5571a02 (patch)
treeb4774b7fb32d096f134fcb0cb6c162d4a652000f /pkgs/development
parentce16bc1d6962e0f93e934ac88fec5d5da4907948 (diff)
parentfbdd16809b2c46fea130f3c7cabac09c1f73b16c (diff)
downloadnixlib-30bdb6a5c831bd87e98d947a47a8ea16d5571a02.tar
nixlib-30bdb6a5c831bd87e98d947a47a8ea16d5571a02.tar.gz
nixlib-30bdb6a5c831bd87e98d947a47a8ea16d5571a02.tar.bz2
nixlib-30bdb6a5c831bd87e98d947a47a8ea16d5571a02.tar.lz
nixlib-30bdb6a5c831bd87e98d947a47a8ea16d5571a02.tar.xz
nixlib-30bdb6a5c831bd87e98d947a47a8ea16d5571a02.tar.zst
nixlib-30bdb6a5c831bd87e98d947a47a8ea16d5571a02.zip
Merge pull request #166860 from fabaff/bump-potentials
python3Packages.potentials: 0.3.2 -> 0.3.3
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/python-modules/atomman/default.nix18
-rw-r--r--pkgs/development/python-modules/potentials/default.nix6
-rw-r--r--pkgs/development/python-modules/pymatgen/default.nix24
-rw-r--r--pkgs/development/python-modules/yabadaba/default.nix57
4 files changed, 88 insertions, 17 deletions
diff --git a/pkgs/development/python-modules/atomman/default.nix b/pkgs/development/python-modules/atomman/default.nix
index 7f5b08fd4fe3..7e1738ad33ad 100644
--- a/pkgs/development/python-modules/atomman/default.nix
+++ b/pkgs/development/python-modules/atomman/default.nix
@@ -1,4 +1,5 @@
 { lib
+, ase
 , buildPythonPackage
 , cython
 , datamodeldict
@@ -7,17 +8,19 @@
 , numericalunits
 , numpy
 , pandas
+, phonopy
 , potentials
+, pymatgen
 , pytest
 , pythonOlder
+, requests
 , scipy
 , toolz
 , xmltodict
-, python
 }:
 
 buildPythonPackage rec {
-  version = "1.4.3";
+  version = "1.4.4";
   pname = "atomman";
   format = "setuptools";
 
@@ -27,7 +30,7 @@ buildPythonPackage rec {
     owner = "usnistgov";
     repo = "atomman";
     rev = "v${version}";
-    sha256 = "sha256-is47O59Pjrh9tPC1Y2+DVVcHbxmcjUOFOVGnNHuURoM=";
+    hash = "sha256-iLAB0KMtrTCyGpx+81QfHDPVDhq8OA6CDL/ipVRpyo0=";
   };
 
   propagatedBuildInputs = [
@@ -38,19 +41,24 @@ buildPythonPackage rec {
     numpy
     pandas
     potentials
+    requests
     scipy
     toolz
     xmltodict
   ];
 
   checkInputs = [
+    ase
+    phonopy
+    pymatgen
     pytest
   ];
 
   checkPhase = ''
     # pytestCheckHook doesn't work
-    py.test tests -k "not test_rootdir and not test_version \
-      and not test_atomic_mass and not imageflags"
+    pytest tests -k "not test_rootdir and not test_version \
+      and not test_atomic_mass and not imageflags" \
+      --ignore tests/plot/test_interpolate.py
   '';
 
   pythonImportsCheck = [
diff --git a/pkgs/development/python-modules/potentials/default.nix b/pkgs/development/python-modules/potentials/default.nix
index f3542c13972e..2d602746815e 100644
--- a/pkgs/development/python-modules/potentials/default.nix
+++ b/pkgs/development/python-modules/potentials/default.nix
@@ -16,10 +16,11 @@
 , scipy
 , unidecode
 , xmltodict
+, yabadaba
 }:
 
 buildPythonPackage rec {
-  version = "0.3.2";
+  version = "0.3.3";
   pname = "potentials";
   format = "setuptools";
 
@@ -27,7 +28,7 @@ buildPythonPackage rec {
 
   src = fetchPypi {
     inherit pname version;
-    sha256 = "sha256-u++ClAAc96u7k8w756sFR4oCtIOgERQ7foklxWWPprY=";
+    hash = "sha256-kj2RDls5ziCH+AF982h8TplZccwdcna3BQMoBXAbOHE=";
   };
 
   propagatedBuildInputs = [
@@ -44,6 +45,7 @@ buildPythonPackage rec {
     scipy
     unidecode
     xmltodict
+    yabadaba
   ];
 
   # Project has no tests
diff --git a/pkgs/development/python-modules/pymatgen/default.nix b/pkgs/development/python-modules/pymatgen/default.nix
index be13f77490ad..545310ec0ade 100644
--- a/pkgs/development/python-modules/pymatgen/default.nix
+++ b/pkgs/development/python-modules/pymatgen/default.nix
@@ -1,6 +1,7 @@
-{ lib, buildPythonPackage, fetchFromGitHub
+{ lib
+, buildPythonPackage
+, fetchFromGitHub
 , cython
-, enum34
 , glibcLocales
 , matplotlib
 , monty
@@ -11,10 +12,10 @@
 , plotly
 , pybtex
 , pydispatcher
+, pythonOlder
 , requests
 , ruamel-yaml
 , scipy
-, six
 , spglib
 , sympy
 , tabulate
@@ -23,14 +24,16 @@
 
 buildPythonPackage rec {
   pname = "pymatgen";
-  version = "2022.2.7";
+  version = "2022.3.29";
+  format = "setuptools";
+
+  disabled = pythonOlder "3.8";
 
-  # sdist doesn't include c files
   src = fetchFromGitHub {
     owner = "materialsproject";
     repo = "pymatgen";
     rev= "v${version}";
-    sha256 = "sha256-92Dxmo1Z9LR2caSOftIf1I6jeZmqDe3SqhhoCofWraw=";
+    hash = "sha256-B2piRWx9TfKlGTPOAAGsq2GxyfHIRBVFpk6dxES0WF0=";
   };
 
   nativeBuildInputs = [
@@ -39,7 +42,6 @@ buildPythonPackage rec {
   ];
 
   propagatedBuildInputs = [
-    enum34
     matplotlib
     monty
     networkx
@@ -52,16 +54,18 @@ buildPythonPackage rec {
     requests
     ruamel-yaml
     scipy
-    six
     spglib
     sympy
     tabulate
     uncertainties
   ];
 
-  # No tests in pypi tarball.
+  # Tests are not detected by pytest
   doCheck = false;
-  pythonImportsCheck = [ "pymatgen" ];
+
+  pythonImportsCheck = [
+    "pymatgen"
+  ];
 
   meta = with lib; {
     description = "A robust materials analysis code that defines core object representations for structures and molecules";
diff --git a/pkgs/development/python-modules/yabadaba/default.nix b/pkgs/development/python-modules/yabadaba/default.nix
new file mode 100644
index 000000000000..d476e10adc76
--- /dev/null
+++ b/pkgs/development/python-modules/yabadaba/default.nix
@@ -0,0 +1,57 @@
+{ lib
+, buildPythonPackage
+, cdcs
+, datamodeldict
+, fetchFromGitHub
+, ipython
+, lxml
+, numpy
+, pandas
+, pymongo
+, pytestCheckHook
+, pythonOlder
+}:
+
+buildPythonPackage rec {
+  pname = "yabadaba";
+  version = "0.1.2";
+  format = "setuptools";
+
+  disabled = pythonOlder "3.7";
+
+  src = fetchFromGitHub {
+    owner = "usnistgov";
+    repo = pname;
+    rev = "v${version}";
+    hash = "sha256-Svw15epiSMEGMuFuMLqX2C9YFGtRtdg7DW2OVLPRmNI=";
+  };
+
+  propagatedBuildInputs = [
+    cdcs
+    datamodeldict
+    ipython
+    lxml
+    numpy
+    pandas
+    pymongo
+  ];
+
+  checkInputs = [
+    pytestCheckHook
+  ];
+
+  pythonImportsCheck = [
+    "yabadaba"
+  ];
+
+  preCheck = ''
+    export HOME=$(mktemp -d);
+  '';
+
+  meta = with lib; {
+    description = "Abstraction layer allowing for common interactions with databases and records";
+    homepage = "https://github.com/usnistgov/yabadaba";
+    license = licenses.mit;
+    maintainers = with maintainers; [ fab ];
+  };
+}