about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorgithub-actions[bot] <41898282+github-actions[bot]@users.noreply.github.com>2021-01-05 00:57:02 +0000
committerGitHub <noreply@github.com>2021-01-05 00:57:02 +0000
commit2f7fa4bb8887cc90f72a2b9173b603c9af9d62ea (patch)
treeff58c9518224f9eb7da040e2b7d12f5264b79622 /pkgs/development
parent16174037b3b66f8a00171df85fd99c210f14c268 (diff)
parent0e4e47512d709e93c35fa575dd82e3e6ce4f884d (diff)
downloadnixlib-2f7fa4bb8887cc90f72a2b9173b603c9af9d62ea.tar
nixlib-2f7fa4bb8887cc90f72a2b9173b603c9af9d62ea.tar.gz
nixlib-2f7fa4bb8887cc90f72a2b9173b603c9af9d62ea.tar.bz2
nixlib-2f7fa4bb8887cc90f72a2b9173b603c9af9d62ea.tar.lz
nixlib-2f7fa4bb8887cc90f72a2b9173b603c9af9d62ea.tar.xz
nixlib-2f7fa4bb8887cc90f72a2b9173b603c9af9d62ea.tar.zst
nixlib-2f7fa4bb8887cc90f72a2b9173b603c9af9d62ea.zip
Merge staging-next into staging
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/interpreters/evcxr/default.nix6
-rw-r--r--pkgs/development/interpreters/python/cpython/3.8/no-ldconfig.patch44
-rw-r--r--pkgs/development/interpreters/python/default.nix4
-rw-r--r--pkgs/development/ocaml-modules/ppx_import/default.nix15
-rw-r--r--pkgs/development/python-modules/flufl/i18n.nix4
-rw-r--r--pkgs/development/tools/rust/racer/default.nix29
6 files changed, 49 insertions, 53 deletions
diff --git a/pkgs/development/interpreters/evcxr/default.nix b/pkgs/development/interpreters/evcxr/default.nix
index a97f132b3b2f..59abf36f7ac0 100644
--- a/pkgs/development/interpreters/evcxr/default.nix
+++ b/pkgs/development/interpreters/evcxr/default.nix
@@ -2,16 +2,16 @@
 
 rustPlatform.buildRustPackage rec {
   pname = "evcxr";
-  version = "0.6.0";
+  version = "0.7.0";
 
   src = fetchFromGitHub {
     owner = "google";
     repo = "evcxr";
     rev = "v${version}";
-    sha256 = "sha256-QpUhUE65/IuT/VenziPX6z+CbJswbPPIv/ZnTthZpEU=";
+    sha256 = "sha256-33XeepqwYmTMcObroPTuxykYuM9qYI1+LV5lZIFSomg=";
   };
 
-  cargoSha256 = "sha256-iUzVd4XtD+41yTV/BmqWLenzAUNPfS7vIHm1KfuPe9A=";
+  cargoSha256 = "sha256-tjCID3YeGkxcq/LqJDMHGNpv1MCXKtcLlDnNkFwx1zU=";
 
   RUST_SRC_PATH = "${rustPlatform.rustLibSrc}";
 
diff --git a/pkgs/development/interpreters/python/cpython/3.8/no-ldconfig.patch b/pkgs/development/interpreters/python/cpython/3.8/no-ldconfig.patch
index 41d3ab52345b..a1f9d68eb166 100644
--- a/pkgs/development/interpreters/python/cpython/3.8/no-ldconfig.patch
+++ b/pkgs/development/interpreters/python/cpython/3.8/no-ldconfig.patch
@@ -1,19 +1,19 @@
-From 66f492d2eda94bd64db833839a325caf6ba0fed5 Mon Sep 17 00:00:00 2001
-From: Greg Roodt <greg@canva.com>
-Date: Wed, 9 Dec 2020 17:59:24 +1100
+From 597e73f2a4b2f0b508127931b36d5540d6941823 Mon Sep 17 00:00:00 2001
+From: Frederik Rietdijk <fridh@fridh.nl>
+Date: Mon, 28 Aug 2017 09:24:06 +0200
 Subject: [PATCH] Don't use ldconfig
 
 ---
- Lib/ctypes/util.py | 77 ++--------------------------------------------
- 1 file changed, 2 insertions(+), 75 deletions(-)
+ Lib/ctypes/util.py | 70 ++----------------------------------------------------
+ 1 file changed, 2 insertions(+), 68 deletions(-)
 
 diff --git a/Lib/ctypes/util.py b/Lib/ctypes/util.py
-index 0c2510e161..7fb98af308 100644
+index 5e8b31a854..7b45ce6c15 100644
 --- a/Lib/ctypes/util.py
 +++ b/Lib/ctypes/util.py
-@@ -100,53 +100,7 @@ elif os.name == "posix":
-             return thefile.read(4) == elf_header
-
+@@ -94,46 +94,7 @@ elif os.name == "posix":
+     import re, tempfile
+ 
      def _findLib_gcc(name):
 -        # Run GCC's linker with the -t (aka --trace) option and examine the
 -        # library name it prints out. The GCC command will fail because we
@@ -51,24 +51,17 @@ index 0c2510e161..7fb98af308 100644
 -                # Raised if the file was already removed, which is the normal
 -                # behaviour of GCC if linking fails
 -                pass
--        res = re.findall(expr, trace)
+-        res = re.search(expr, trace)
 -        if not res:
 -            return None
--
--        for file in res:
--            # Check if the given file is an elf file: gcc can report
--            # some files that are linker scripts and not actual
--            # shared objects. See bpo-41976 for more details
--            if not _is_elf(file):
--                continue
--            return os.fsdecode(file)
+-        return os.fsdecode(res.group(0))
 +        return None
-
-
+ 
+ 
      if sys.platform == "sunos5":
-@@ -268,34 +222,7 @@ elif os.name == "posix":
+@@ -255,34 +216,7 @@ elif os.name == "posix":
      else:
-
+ 
          def _findSoname_ldconfig(name):
 -            import struct
 -            if struct.calcsize('l') == 4:
@@ -99,8 +92,9 @@ index 0c2510e161..7fb98af308 100644
 -            except OSError:
 -                pass
 +            return None
-
+ 
          def _findLib_ld(name):
              # See issue #9998 for why this is needed
---
-2.24.3 (Apple Git-128)
+-- 
+2.15.0
+
diff --git a/pkgs/development/interpreters/python/default.nix b/pkgs/development/interpreters/python/default.nix
index 70a4731ea6d6..a217f62986db 100644
--- a/pkgs/development/interpreters/python/default.nix
+++ b/pkgs/development/interpreters/python/default.nix
@@ -154,10 +154,10 @@ in {
     sourceVersion = {
       major = "3";
       minor = "8";
-      patch = "7";
+      patch = "6";
       suffix = "";
     };
-    sha256 = "sha256-3cwd8Wu1uHqkLsXSCluQLy0IjKommyjgFZD5enmOxQo=";
+    sha256 = "qeC3nSeqBW65zOjWOkJ7X5urFGXe4/lC3P2yWoL0q4o=";
     inherit (darwin) configd;
     inherit passthruFun;
   };
diff --git a/pkgs/development/ocaml-modules/ppx_import/default.nix b/pkgs/development/ocaml-modules/ppx_import/default.nix
index f4977992759d..b5651a8cec2a 100644
--- a/pkgs/development/ocaml-modules/ppx_import/default.nix
+++ b/pkgs/development/ocaml-modules/ppx_import/default.nix
@@ -1,24 +1,27 @@
 { lib, fetchurl, buildDunePackage, ocaml
 , ounit, ppx_deriving, ppx_tools_versioned
+, ppxlib, ocaml-migrate-parsetree
 }:
 
-if !lib.versionAtLeast ocaml.version "4.04"
-then throw "ppx_import is not available for OCaml ${ocaml.version}"
-else
-
 buildDunePackage rec {
   pname = "ppx_import";
   version = "1.7.1";
 
+  useDune2 = true;
+
+  minimumOCamlVersion = "4.04";
+
   src = fetchurl {
     url = "https://github.com/ocaml-ppx/ppx_import/releases/download/v${version}/ppx_import-v${version}.tbz";
     sha256 = "16dyxfb7syz659rqa7yq36ny5vzl7gkqd7f4m6qm2zkjc1gc8j4v";
   };
 
-  buildInputs = [ ounit ppx_deriving ];
-  propagatedBuildInputs = [ ppx_tools_versioned ];
+  propagatedBuildInputs = [
+    ppxlib ppx_tools_versioned ocaml-migrate-parsetree
+  ];
 
   doCheck = true;
+  checkInputs = [ ounit ppx_deriving ];
 
   meta = {
     description = "A syntax extension that allows to pull in types or signatures from other compiled interface files";
diff --git a/pkgs/development/python-modules/flufl/i18n.nix b/pkgs/development/python-modules/flufl/i18n.nix
index b980449661ee..8b0c98635507 100644
--- a/pkgs/development/python-modules/flufl/i18n.nix
+++ b/pkgs/development/python-modules/flufl/i18n.nix
@@ -2,7 +2,7 @@
 
 buildPythonPackage rec {
   pname = "flufl.i18n";
-  version = "3.1.3";
+  version = "3.1.4";
 
   propagatedBuildInputs = [ atpublic ];
 
@@ -12,6 +12,6 @@ buildPythonPackage rec {
 
   src = fetchPypi {
     inherit pname version;
-    sha256 = "dcca738be27f2c43ddf6f9307667a17478353190071f38a9f92c9af8d2252ba4";
+    sha256 = "e19036292a825a69f0e0a87566d1628830c69eecd3b0295d22f582039477a6bb";
   };
 }
diff --git a/pkgs/development/tools/rust/racer/default.nix b/pkgs/development/tools/rust/racer/default.nix
index 86f1989729eb..7de30855dd37 100644
--- a/pkgs/development/tools/rust/racer/default.nix
+++ b/pkgs/development/tools/rust/racer/default.nix
@@ -2,16 +2,16 @@
 
 rustPlatform.buildRustPackage rec {
   pname = "racer";
-  version = "2.1.35";
+  version = "2.1.40";
 
   src = fetchFromGitHub {
     owner = "racer-rust";
     repo = "racer";
     rev = "v${version}";
-    sha256 = "0c00b81s7abnadjbf4i39lhdkipx7z44sr8p78jd1fl61yyrspli";
+    sha256 = "sha256-8Is+RBfcXKbGSFzYoolLHs30rxlNI//xVGEOhxP2TV8=";
   };
 
-  cargoSha256 = "1nbp2jp65fqwsq9i04iyi4pbszs035w6id50p5ypw234cqxznikm";
+  cargoSha256 = "sha256-iUomr9viCdZk4nV75/OP8vHtJpMbmy+pq1IbaA2lLmE=";
 
   nativeBuildInputs = [ makeWrapper ];
   buildInputs = stdenv.lib.optional stdenv.isDarwin Security;
@@ -19,21 +19,20 @@ rustPlatform.buildRustPackage rec {
   # a nightly compiler is required unless we use this cheat code.
   RUSTC_BOOTSTRAP = 1;
 
-  RUST_SRC_PATH = rustPlatform.rustcSrc;
+  RUST_SRC_PATH = rustPlatform.rustLibSrc;
   postInstall = ''
-    wrapProgram $out/bin/racer --set-default RUST_SRC_PATH ${rustPlatform.rustcSrc}
+    wrapProgram $out/bin/racer --set-default RUST_SRC_PATH ${rustPlatform.rustLibSrc}
   '';
 
-  checkPhase = ''
-    cargo test -- \
-      --skip nameres::test_do_file_search_std \
-      --skip util::test_get_rust_src_path_rustup_ok \
-      --skip util::test_get_rust_src_path_not_rust_source_tree \
-      --skip extern --skip completes_pub_fn --skip find_crate_doc \
-      --skip follows_use_local_package --skip follows_use_for_reexport \
-      --skip follows_rand_crate --skip get_completion_in_example_dir \
-      --skip test_resolve_global_path_in_modules
-  '';
+  checkFlags = [
+    "--skip nameres::test_do_file_search_std"
+    "--skip util::test_get_rust_src_path_rustup_ok"
+    "--skip util::test_get_rust_src_path_not_rust_source_tree"
+    "--skip extern --skip completes_pub_fn --skip find_crate_doc"
+    "--skip follows_use_local_package --skip follows_use_for_reexport"
+    "--skip follows_rand_crate --skip get_completion_in_example_dir"
+    "--skip test_resolve_global_path_in_modules"
+  ];
 
   doInstallCheck = true;
   installCheckPhase = ''