about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorMichael Alan Dorman <mdorman@ironicdesign.com>2016-04-05 07:14:48 -0400
committerPeter Simons <simons@cryp.to>2016-04-07 07:53:57 +0200
commit2daf67bf87db9cb9964d91c0b4c2ffc24887cf37 (patch)
tree90fb7eaaa4946a4cb2599847e6d18100604d2175 /pkgs/development
parente6e5d984aba2ff0d2c1f0442686e056625c9a37f (diff)
downloadnixlib-2daf67bf87db9cb9964d91c0b4c2ffc24887cf37.tar
nixlib-2daf67bf87db9cb9964d91c0b4c2ffc24887cf37.tar.gz
nixlib-2daf67bf87db9cb9964d91c0b4c2ffc24887cf37.tar.bz2
nixlib-2daf67bf87db9cb9964d91c0b4c2ffc24887cf37.tar.lz
nixlib-2daf67bf87db9cb9964d91c0b4c2ffc24887cf37.tar.xz
nixlib-2daf67bf87db9cb9964d91c0b4c2ffc24887cf37.tar.zst
nixlib-2daf67bf87db9cb9964d91c0b4c2ffc24887cf37.zip
haskell-pipes-transduce: fix build
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/haskell-modules/configuration-common.nix5
1 files changed, 5 insertions, 0 deletions
diff --git a/pkgs/development/haskell-modules/configuration-common.nix b/pkgs/development/haskell-modules/configuration-common.nix
index 8f3c2ad1a6f8..f40b1281e6bf 100644
--- a/pkgs/development/haskell-modules/configuration-common.nix
+++ b/pkgs/development/haskell-modules/configuration-common.nix
@@ -965,5 +965,10 @@ self: super: {
     dns_sd = pkgs.avahi.override {
       withLibdnssdCompat = true;
     };
+
+  # https://github.com/danidiaz/pipes-transduce/issues/2
+  pipes-transduce = super.pipes-transduce.override {
+    foldl = self.foldl_1_1_6;
   };
+
 }