about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorChris Ostrouchov <chris.ostrouchov@gmail.com>2018-10-27 17:32:44 -0400
committerChris Ostrouchov <chris.ostrouchov@gmail.com>2018-10-30 00:50:49 -0400
commit2caa59c9574a2c45963c7adb0dc852a9f6b7321c (patch)
tree09c803156cfd7aba970f2c211405c39b5fc9bd0b /pkgs/development
parent44713571fc1cf57973dcbb248fe395441c87c321 (diff)
downloadnixlib-2caa59c9574a2c45963c7adb0dc852a9f6b7321c.tar
nixlib-2caa59c9574a2c45963c7adb0dc852a9f6b7321c.tar.gz
nixlib-2caa59c9574a2c45963c7adb0dc852a9f6b7321c.tar.bz2
nixlib-2caa59c9574a2c45963c7adb0dc852a9f6b7321c.tar.lz
nixlib-2caa59c9574a2c45963c7adb0dc852a9f6b7321c.tar.xz
nixlib-2caa59c9574a2c45963c7adb0dc852a9f6b7321c.tar.zst
nixlib-2caa59c9574a2c45963c7adb0dc852a9f6b7321c.zip
pythonPackages.sphinxcontrib-spelling: refactor move to python-modules
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/python-modules/sphinxcontrib-spelling/default.nix30
1 files changed, 30 insertions, 0 deletions
diff --git a/pkgs/development/python-modules/sphinxcontrib-spelling/default.nix b/pkgs/development/python-modules/sphinxcontrib-spelling/default.nix
new file mode 100644
index 000000000000..4d9a4b2ba94c
--- /dev/null
+++ b/pkgs/development/python-modules/sphinxcontrib-spelling/default.nix
@@ -0,0 +1,30 @@
+{ stdenv
+, buildPythonPackage
+, fetchPypi
+, sphinx
+, pyenchant
+, pbr
+}:
+
+buildPythonPackage rec {
+  pname = "sphinxcontrib-spelling";
+  version = "2.2.0";
+
+  src = fetchPypi {
+    inherit pname version;
+    sha256 = "1f0fymrk4kvhqs0vj9gay4lhacxkfrlrpj4gvg0p4wjdczplxd3z";
+  };
+
+  propagatedBuildInputs = [ sphinx pyenchant pbr ];
+
+  # No tests included
+  doCheck = false;
+
+  meta = with stdenv.lib; {
+    description = "Sphinx spelling extension";
+    homepage = https://bitbucket.org/dhellmann/sphinxcontrib-spelling;
+    maintainers = with maintainers; [ nand0p ];
+    license = licenses.bsd2;
+  };
+
+}