about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorEdward Tjörnhammar <ed@cflags.cc>2016-04-27 17:59:08 +0200
committerEdward Tjörnhammar <ed@cflags.cc>2016-04-27 18:02:06 +0200
commit2b384d401d5cd2a33be4261fc05d1684ebe02be6 (patch)
treebd210580830920cf274d5c4b980883643fbca57e /pkgs/development
parent0307ab1f3743cc0bc0c4a0439dcd5df0c68f8605 (diff)
downloadnixlib-2b384d401d5cd2a33be4261fc05d1684ebe02be6.tar
nixlib-2b384d401d5cd2a33be4261fc05d1684ebe02be6.tar.gz
nixlib-2b384d401d5cd2a33be4261fc05d1684ebe02be6.tar.bz2
nixlib-2b384d401d5cd2a33be4261fc05d1684ebe02be6.tar.lz
nixlib-2b384d401d5cd2a33be4261fc05d1684ebe02be6.tar.xz
nixlib-2b384d401d5cd2a33be4261fc05d1684ebe02be6.tar.zst
nixlib-2b384d401d5cd2a33be4261fc05d1684ebe02be6.zip
tsocks: switch back to regular stdenv libc, remove saveme compilation
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/libraries/tsocks/default.nix13
1 files changed, 11 insertions, 2 deletions
diff --git a/pkgs/development/libraries/tsocks/default.nix b/pkgs/development/libraries/tsocks/default.nix
index 778762f1bf87..149b2260792f 100644
--- a/pkgs/development/libraries/tsocks/default.nix
+++ b/pkgs/development/libraries/tsocks/default.nix
@@ -1,4 +1,5 @@
 { stdenv, fetchurl }:
+
 stdenv.mkDerivation rec {
   name = "tsocks-${version}";
   version = "1.8beta5";
@@ -16,11 +17,19 @@ stdenv.mkDerivation rec {
     export configureFlags="$configureFlags --libdir=$out/lib"
   '';
 
+  preBuild = ''
+    # We don't need the saveme binary, it is in fact never stored and we're
+    # never injecting stuff into ld.so.preload anyway
+    sed -i \
+      -e "s,TARGETS=\(.*\)..SAVE.\(.*\),TARGETS=\1\2," \
+      -e "/SAVE/d" Makefile
+  '';
+
   meta = with stdenv.lib; {
     description = "Transparent SOCKS v4 proxying library";
     homepage = http://tsocks.sourceforge.net/;
     license = stdenv.lib.licenses.gpl2;
     maintainers = with maintainers; [ edwtjo phreedom ];
-    platforms = platforms.linux;
+    platforms = platforms.unix;
   };
-}
\ No newline at end of file
+}