about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorThor A. Hopland <thorhop@gmail.com>2015-02-06 06:53:32 +0100
committerThor A. Hopland <thorhop@gmail.com>2015-02-06 06:53:32 +0100
commit28b8c50c2dab82447857611f87a704ffb3645fa6 (patch)
tree4bfc79d9795b06db27187ea9ad14f46e778b1779 /pkgs/development
parent934910acdda79970ced54c1c9c961d0e142807d3 (diff)
downloadnixlib-28b8c50c2dab82447857611f87a704ffb3645fa6.tar
nixlib-28b8c50c2dab82447857611f87a704ffb3645fa6.tar.gz
nixlib-28b8c50c2dab82447857611f87a704ffb3645fa6.tar.bz2
nixlib-28b8c50c2dab82447857611f87a704ffb3645fa6.tar.lz
nixlib-28b8c50c2dab82447857611f87a704ffb3645fa6.tar.xz
nixlib-28b8c50c2dab82447857611f87a704ffb3645fa6.tar.zst
nixlib-28b8c50c2dab82447857611f87a704ffb3645fa6.zip
Added Touchegg and 3 depdenencies. Touchegg is a daemon for X that adds gesture based navigation for touch based surfaces.
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/libraries/frame/default.nix24
-rw-r--r--pkgs/development/libraries/geis/default.nix23
-rw-r--r--pkgs/development/libraries/grail/default.nix23
3 files changed, 70 insertions, 0 deletions
diff --git a/pkgs/development/libraries/frame/default.nix b/pkgs/development/libraries/frame/default.nix
new file mode 100644
index 000000000000..86ebaa0d8d91
--- /dev/null
+++ b/pkgs/development/libraries/frame/default.nix
@@ -0,0 +1,24 @@
+{ enableX11 ? true
+,  stdenv, fetchurl, pkgconfig, xlibs, xorgserver, xinput }:
+
+stdenv.mkDerivation rec {
+  name = "frame-${version}";
+  version = "2.5.0";
+  src = fetchurl {
+    url = "https://launchpad.net/frame/trunk/v${version}/+download/${name}.tar.xz";
+    sha256 = "bc2a20cd3ac1e61fe0461bd3ee8cb250dbcc1fa511fad0686d267744e9c78f3a";
+  };
+
+  buildInputs = [ 
+    stdenv pkgconfig
+  ] ++ stdenv.lib.optional enableX11 [xlibs.xorgserver xlibs.libX11 xlibs.libXext xlibs.libXi];
+
+  configureFlags = stdenv.lib.optional enableX11 "--with-x11";
+
+  meta = {
+    homepage = "https://launchpad.net/frame";
+    description = "handles the buildup and synchronization of a set of simultaneous touches";
+    license = stdenv.lib.licenses.gpl3;
+    platforms = stdenv.lib.platforms.linux;
+  };
+}
\ No newline at end of file
diff --git a/pkgs/development/libraries/geis/default.nix b/pkgs/development/libraries/geis/default.nix
new file mode 100644
index 000000000000..15f42afd9a8e
--- /dev/null
+++ b/pkgs/development/libraries/geis/default.nix
@@ -0,0 +1,23 @@
+{ enableX11 ? true
+, stdenv, fetchurl, pkgconfig, xlibs, xorgserver, python3, dbus_libs, frame, grail }:
+
+stdenv.mkDerivation rec {
+  name = "geis-${version}";
+  version = "2.2.16";
+  src = fetchurl {
+    url = "https://launchpad.net/geis/trunk/${version}/+download/${name}.tar.xz";
+    sha256 = "40a694092c79f325a2fbf8a9f301177bc91c364f4e637c2aa8963ad2a5aabbcf";
+  };
+
+  buildInputs = [ pkgconfig python3 dbus_libs frame grail ]
+  ++ stdenv.lib.optional enableX11 [xlibs.libX11 xlibs.libXtst xlibs.libXext xlibs.libXi xlibs.xorgserver];
+
+  configureFlags = stdenv.lib.optional enableX11"--enable-x11";
+
+  meta = {
+    homepage = "https://launchpad.net/geis";
+    description = "GEIS is a library for applications and toolkit programmers which provides a consistent platform independent interface for any system-wide input gesture recognition mechanism.";
+    license = stdenv.lib.licenses.gpl2;
+    platforms = stdenv.lib.platforms.linux;
+  };
+}
\ No newline at end of file
diff --git a/pkgs/development/libraries/grail/default.nix b/pkgs/development/libraries/grail/default.nix
new file mode 100644
index 000000000000..3cf946bb4ba5
--- /dev/null
+++ b/pkgs/development/libraries/grail/default.nix
@@ -0,0 +1,23 @@
+{ enableX11 ? true,
+  stdenv, fetchurl, pkgconfig, xlibs, python3, frame }:
+
+stdenv.mkDerivation rec {
+  name = "grail-${version}";
+  version = "3.1.0";
+  src = fetchurl {
+    url = "https://launchpad.net/grail/trunk/${version}/+download/${name}.tar.bz2";
+    sha256 = "c26dced1b3f4317ecf6af36db0e90294d87e43966d56aecc4e97b65368ab78b9";
+  };
+
+  buildInputs = [ pkgconfig python3 frame ]
+  ++ stdenv.lib.optional enableX11 [xlibs.libX11 xlibs.libXtst xlibs.libXext xlibs.libXi xlibs.libXfixes];
+
+  configureFlags = stdenv.lib.optional enableX11 "--with-x11";
+
+  meta = {
+    homepage = "https://launchpad.net/canonical-multitouch/grail";
+    description = "Gesture Recognition And Instantiation Library";
+    license = stdenv.lib.licenses.gpl2;
+    platforms = stdenv.lib.platforms.linux;
+  };
+}
\ No newline at end of file