about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorRicardo M. Correia <rcorreia@wizy.org>2016-02-17 18:54:58 +0100
committerRicardo M. Correia <rcorreia@wizy.org>2016-02-17 20:42:14 +0100
commit26415f963aec8dee29f8dab6ca1b36124f8b0abc (patch)
tree690752163ed836862a4c5486bdba1685a52213d0 /pkgs/development
parenta1e96c7cbe74f4c826eb55aad498f70ce345393e (diff)
downloadnixlib-26415f963aec8dee29f8dab6ca1b36124f8b0abc.tar
nixlib-26415f963aec8dee29f8dab6ca1b36124f8b0abc.tar.gz
nixlib-26415f963aec8dee29f8dab6ca1b36124f8b0abc.tar.bz2
nixlib-26415f963aec8dee29f8dab6ca1b36124f8b0abc.tar.lz
nixlib-26415f963aec8dee29f8dab6ca1b36124f8b0abc.tar.xz
nixlib-26415f963aec8dee29f8dab6ca1b36124f8b0abc.tar.zst
nixlib-26415f963aec8dee29f8dab6ca1b36124f8b0abc.zip
ocamlPackages.containers: init at 0.15
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/ocaml-modules/containers/default.nix47
1 files changed, 47 insertions, 0 deletions
diff --git a/pkgs/development/ocaml-modules/containers/default.nix b/pkgs/development/ocaml-modules/containers/default.nix
new file mode 100644
index 000000000000..5c2447614ada
--- /dev/null
+++ b/pkgs/development/ocaml-modules/containers/default.nix
@@ -0,0 +1,47 @@
+{ stdenv, fetchFromGitHub, ocaml, findlib, cppo, gen, sequence, qtest, ounit }:
+
+let version = "0.15"; in
+
+stdenv.mkDerivation {
+  name = "ocaml-containers-${version}";
+
+  src = fetchFromGitHub {
+    owner = "c-cube";
+    repo = "ocaml-containers";
+    rev = "${version}";
+    sha256 = "13mdl8jp4ymg1wip7lqmh4224x4jnji3frm1ik55vvm3ac8caqng";
+  };
+
+  buildInputs = [ ocaml findlib cppo gen sequence qtest ounit ];
+
+  configureFlags = [
+    "--enable-unix"
+    "--enable-thread"
+    "--enable-bigarray"
+    "--enable-advanced"
+    "--enable-tests"
+    "--disable-bench"
+  ];
+
+  doCheck = true;
+  checkTarget = "test";
+
+  createFindlibDestdir = true;
+
+  meta = {
+    homepage = https://github.com/c-cube/ocaml-containers;
+    description = "A modular standard library focused on data structures";
+    longDescription = ''
+      Containers is a standard library (BSD license) focused on data structures,
+      combinators and iterators, without dependencies on unix. Every module is
+      independent and is prefixed with 'CC' in the global namespace. Some modules
+      extend the stdlib (e.g. CCList provides safe map/fold_right/append, and
+      additional functions on lists).
+
+      It also features optional libraries for dealing with strings, and
+      helpers for unix and threads.
+    '';
+    license = stdenv.lib.licenses.bsd2;
+    platforms = ocaml.meta.platforms;
+  };
+}