about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorJohn Ericson <John.Ericson@Obsidian.Systems>2018-07-23 17:35:23 -0400
committerJohn Ericson <John.Ericson@Obsidian.Systems>2018-08-02 15:12:45 -0400
commit25348b27c5b78877800eb0ec77b8e26219002b75 (patch)
treebc7dcc6da9620a71442f941c9a574e49e6f6703a /pkgs/development
parentf83b5e4f7a7e1136237b434811914f3c79f43c46 (diff)
downloadnixlib-25348b27c5b78877800eb0ec77b8e26219002b75.tar
nixlib-25348b27c5b78877800eb0ec77b8e26219002b75.tar.gz
nixlib-25348b27c5b78877800eb0ec77b8e26219002b75.tar.bz2
nixlib-25348b27c5b78877800eb0ec77b8e26219002b75.tar.lz
nixlib-25348b27c5b78877800eb0ec77b8e26219002b75.tar.xz
nixlib-25348b27c5b78877800eb0ec77b8e26219002b75.tar.zst
nixlib-25348b27c5b78877800eb0ec77b8e26219002b75.zip
flex: Clean up to use less bash
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/tools/parsing/flex/default.nix8
1 files changed, 4 insertions, 4 deletions
diff --git a/pkgs/development/tools/parsing/flex/default.nix b/pkgs/development/tools/parsing/flex/default.nix
index 17323a06cc18..1bff2076b9ab 100644
--- a/pkgs/development/tools/parsing/flex/default.nix
+++ b/pkgs/development/tools/parsing/flex/default.nix
@@ -30,10 +30,10 @@ stdenv.mkDerivation rec {
   buildInputs = [ bison ];
   propagatedBuildInputs = [ m4 ];
 
-  preConfigure = stdenv.lib.optionalString (stdenv.buildPlatform != stdenv.hostPlatform) ''
-    export ac_cv_func_malloc_0_nonnull=yes
-    export ac_cv_func_realloc_0_nonnull=yes
-  '';
+  preConfigure = stdenv.lib.optionals (stdenv.hostPlatform != stdenv.buildPlatform) [
+    "ac_cv_func_malloc_0_nonnull=yes"
+    "ac_cv_func_realloc_0_nonnull=yes"
+  ];
 
   postConfigure = stdenv.lib.optionalString (stdenv.isDarwin || stdenv.isCygwin) ''
     sed -i Makefile -e 's/-no-undefined//;'