about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorRobin Gloster <mail@glob.in>2016-02-21 11:41:04 +0000
committerRobin Gloster <mail@glob.in>2016-02-21 11:41:04 +0000
commit23b4e6e19d346c2e96a8f665678184cddda44721 (patch)
tree32958dc3cd5889452773505d31b02e14722d30ea /pkgs/development
parent1eed9435d55fbe12b36f58a924f9448f727ca8ab (diff)
downloadnixlib-23b4e6e19d346c2e96a8f665678184cddda44721.tar
nixlib-23b4e6e19d346c2e96a8f665678184cddda44721.tar.gz
nixlib-23b4e6e19d346c2e96a8f665678184cddda44721.tar.bz2
nixlib-23b4e6e19d346c2e96a8f665678184cddda44721.tar.lz
nixlib-23b4e6e19d346c2e96a8f665678184cddda44721.tar.xz
nixlib-23b4e6e19d346c2e96a8f665678184cddda44721.tar.zst
nixlib-23b4e6e19d346c2e96a8f665678184cddda44721.zip
haskellPackages: remove unnecessary hardening handling
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/haskell-modules/generic-builder.nix2
1 files changed, 0 insertions, 2 deletions
diff --git a/pkgs/development/haskell-modules/generic-builder.nix b/pkgs/development/haskell-modules/generic-builder.nix
index fb8781bd7504..b871b7d73faa 100644
--- a/pkgs/development/haskell-modules/generic-builder.nix
+++ b/pkgs/development/haskell-modules/generic-builder.nix
@@ -45,7 +45,6 @@
 , checkPhase ? "", preCheck ? "", postCheck ? ""
 , preFixup ? "", postFixup ? ""
 , shellHook ? ""
-, hardening_fortify ? true
 , coreSetup ? false # Use only core packages to build Setup.hs.
 , useCpphs ? false
 } @ args:
@@ -320,6 +319,5 @@ stdenv.mkDerivation ({
 // optionalAttrs (preFixup != "")       { inherit preFixup; }
 // optionalAttrs (postFixup != "")      { inherit postFixup; }
 // optionalAttrs (dontStrip)            { inherit dontStrip; }
-// optionalAttrs (!hardening_fortify)   { inherit hardening_fortify; }
 // optionalAttrs (stdenv.isLinux)       { LOCALE_ARCHIVE = "${glibcLocales}/lib/locale/locale-archive"; }
 )