about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorTom Hall <tahall256@protonmail.ch>2018-11-10 18:40:12 +0000
committerTom Hall <tahall256@protonmail.ch>2018-11-10 19:56:11 +0000
commit230f71477bdd051e203d63c123b2a5cb7fed65a4 (patch)
tree932bbd8b746e3e53154c8454c943862301bc156f /pkgs/development
parentb90bc0b2e3343e5c609163e3ae8c185dfc8ff1c7 (diff)
downloadnixlib-230f71477bdd051e203d63c123b2a5cb7fed65a4.tar
nixlib-230f71477bdd051e203d63c123b2a5cb7fed65a4.tar.gz
nixlib-230f71477bdd051e203d63c123b2a5cb7fed65a4.tar.bz2
nixlib-230f71477bdd051e203d63c123b2a5cb7fed65a4.tar.lz
nixlib-230f71477bdd051e203d63c123b2a5cb7fed65a4.tar.xz
nixlib-230f71477bdd051e203d63c123b2a5cb7fed65a4.tar.zst
nixlib-230f71477bdd051e203d63c123b2a5cb7fed65a4.zip
qtwebglplugin: init at 5.11
Note: As with all Qt plugins, must set QT_QPA_PLATFORM_PLUGIN_PATH=~/.nix-profile/lib/qt-5.11/plugins for it to be found.
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/libraries/qt-5/5.11/default.nix1
-rw-r--r--pkgs/development/libraries/qt-5/modules/qtwebglplugin.nix6
2 files changed, 7 insertions, 0 deletions
diff --git a/pkgs/development/libraries/qt-5/5.11/default.nix b/pkgs/development/libraries/qt-5/5.11/default.nix
index bc4b0a8f33be..57300878e49d 100644
--- a/pkgs/development/libraries/qt-5/5.11/default.nix
+++ b/pkgs/development/libraries/qt-5/5.11/default.nix
@@ -113,6 +113,7 @@ let
       qtwayland = callPackage ../modules/qtwayland.nix {};
       qtwebchannel = callPackage ../modules/qtwebchannel.nix {};
       qtwebengine = callPackage ../modules/qtwebengine.nix {};
+      qtwebglplugin = callPackage ../modules/qtwebglplugin.nix {};
       qtwebkit = callPackage ../modules/qtwebkit.nix {};
       qtwebsockets = callPackage ../modules/qtwebsockets.nix {};
       qtx11extras = callPackage ../modules/qtx11extras.nix {};
diff --git a/pkgs/development/libraries/qt-5/modules/qtwebglplugin.nix b/pkgs/development/libraries/qt-5/modules/qtwebglplugin.nix
new file mode 100644
index 000000000000..444d0c1beae8
--- /dev/null
+++ b/pkgs/development/libraries/qt-5/modules/qtwebglplugin.nix
@@ -0,0 +1,6 @@
+{ qtModule, qtbase, qtwebsockets }:
+
+qtModule {
+  name = "qtwebglplugin";
+  qtInputs = [ qtbase qtwebsockets ];
+}