about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorThomas Tuegel <ttuegel@mailbox.org>2017-07-21 07:40:23 -0500
committerThomas Tuegel <ttuegel@mailbox.org>2017-07-21 15:47:12 -0500
commit20321f66d7f8b434b84d4f3f4cb6353367256bc7 (patch)
treefeaa65ec9b26f8790fddf16e76d5999bb5a416e2 /pkgs/development
parent631f6b3e11c7d36bcdab2b11b5bb6ca7361a2e00 (diff)
downloadnixlib-20321f66d7f8b434b84d4f3f4cb6353367256bc7.tar
nixlib-20321f66d7f8b434b84d4f3f4cb6353367256bc7.tar.gz
nixlib-20321f66d7f8b434b84d4f3f4cb6353367256bc7.tar.bz2
nixlib-20321f66d7f8b434b84d4f3f4cb6353367256bc7.tar.lz
nixlib-20321f66d7f8b434b84d4f3f4cb6353367256bc7.tar.xz
nixlib-20321f66d7f8b434b84d4f3f4cb6353367256bc7.tar.zst
nixlib-20321f66d7f8b434b84d4f3f4cb6353367256bc7.zip
x264: unset AS
Commit 093cc00cdd9d8cf31ecce5bc1dd3645c460a1b98 sets the environment variable
`AS' to the binutils assembler, but x264 needs yasm.
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/libraries/x264/default.nix5
1 files changed, 5 insertions, 0 deletions
diff --git a/pkgs/development/libraries/x264/default.nix b/pkgs/development/libraries/x264/default.nix
index 6e4dc00b0387..bf32969836ca 100644
--- a/pkgs/development/libraries/x264/default.nix
+++ b/pkgs/development/libraries/x264/default.nix
@@ -15,6 +15,11 @@ stdenv.mkDerivation rec {
 
   outputs = [ "out" "lib" ]; # leaving 52 kB of headers
 
+  preConfigure = ''
+    # `AS' is set to the binutils assembler, but we need yasm
+    unset AS
+  '';
+
   configureFlags = [ "--enable-shared" ]
     ++ stdenv.lib.optional (!stdenv.isi686) "--enable-pic"
     ++ stdenv.lib.optional (enable10bit) "--bit-depth=10";