about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorPatrick Hilhorst <git@hilhorst.be>2018-11-05 00:26:05 +0100
committerPatrick Hilhorst <git@hilhorst.be>2018-11-06 00:17:04 +0100
commit1e99582eaff5605947b8e9cdef7d440df8cf7ba3 (patch)
treec9200342721e6db2ced16bf1a43ebdaa95c8598d /pkgs/development
parentd2e6608aa520b17a45a39cdfbefd0240bd56b332 (diff)
downloadnixlib-1e99582eaff5605947b8e9cdef7d440df8cf7ba3.tar
nixlib-1e99582eaff5605947b8e9cdef7d440df8cf7ba3.tar.gz
nixlib-1e99582eaff5605947b8e9cdef7d440df8cf7ba3.tar.bz2
nixlib-1e99582eaff5605947b8e9cdef7d440df8cf7ba3.tar.lz
nixlib-1e99582eaff5605947b8e9cdef7d440df8cf7ba3.tar.xz
nixlib-1e99582eaff5605947b8e9cdef7d440df8cf7ba3.tar.zst
nixlib-1e99582eaff5605947b8e9cdef7d440df8cf7ba3.zip
treewide: for substituteAll: s/version/version_/
This is because it gets passed to mkDerivation through some route, this ensures
that doesn't mess with anything
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/python-modules/py3exiv2/default.nix2
-rw-r--r--pkgs/development/python-modules/py3exiv2/setup.patch6
2 files changed, 4 insertions, 4 deletions
diff --git a/pkgs/development/python-modules/py3exiv2/default.nix b/pkgs/development/python-modules/py3exiv2/default.nix
index 4c6ca0bad338..647fbdd872ce 100644
--- a/pkgs/development/python-modules/py3exiv2/default.nix
+++ b/pkgs/development/python-modules/py3exiv2/default.nix
@@ -19,7 +19,7 @@ buildPythonPackage rec {
   patches = [
     (substituteAll {
       src = ./setup.patch;
-      version = "3${stdenv.lib.versions.minor python.version}";
+      version_ = "3${stdenv.lib.versions.minor python.version}";
     })
   ];
 
diff --git a/pkgs/development/python-modules/py3exiv2/setup.patch b/pkgs/development/python-modules/py3exiv2/setup.patch
index 8b0619c5bc5f..784533105d6b 100644
--- a/pkgs/development/python-modules/py3exiv2/setup.patch
+++ b/pkgs/development/python-modules/py3exiv2/setup.patch
@@ -3,9 +3,9 @@
 @@ -39,7 +39,7 @@
                  if '3' in l[2:]:
                      return l.replace('libboost', 'boost')
- 
+
 -libboost = get_libboost_name()
-+libboost = 'boost_python@version@'
- 
++libboost = 'boost_python@version_@'
+
  setup(
      name='py3exiv2',