about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorFranz Pletz <fpletz@fnordicwalking.de>2019-01-17 12:24:58 +0100
committerFranz Pletz <fpletz@fnordicwalking.de>2019-06-17 07:26:01 +0200
commit1cdaba0c7442d8b8185c218dc464434e67e9148c (patch)
treea2964e0cc2dd115dd4b232c3abedbe960c9565f8 /pkgs/development
parent394bee72dbebfa4519cedcee6d32aae5453ef178 (diff)
downloadnixlib-1cdaba0c7442d8b8185c218dc464434e67e9148c.tar
nixlib-1cdaba0c7442d8b8185c218dc464434e67e9148c.tar.gz
nixlib-1cdaba0c7442d8b8185c218dc464434e67e9148c.tar.bz2
nixlib-1cdaba0c7442d8b8185c218dc464434e67e9148c.tar.lz
nixlib-1cdaba0c7442d8b8185c218dc464434e67e9148c.tar.xz
nixlib-1cdaba0c7442d8b8185c218dc464434e67e9148c.tar.zst
nixlib-1cdaba0c7442d8b8185c218dc464434e67e9148c.zip
gnuapl: fix build with gcc8
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/interpreters/gnu-apl/default.nix10
1 files changed, 7 insertions, 3 deletions
diff --git a/pkgs/development/interpreters/gnu-apl/default.nix b/pkgs/development/interpreters/gnu-apl/default.nix
index f60e5d286140..39a2f507e630 100644
--- a/pkgs/development/interpreters/gnu-apl/default.nix
+++ b/pkgs/development/interpreters/gnu-apl/default.nix
@@ -11,9 +11,13 @@ stdenv.mkDerivation rec {
 
   buildInputs = [ readline gettext ncurses ];
 
-  # Needed with GCC 7
-  NIX_CFLAGS_COMPILE = stdenv.lib.optionalString stdenv.cc.isGNU "-Wno-error=int-in-bool-context"
-    + stdenv.lib.optionalString stdenv.cc.isClang "-Wno-error=null-dereference";
+  # Needed with GCC 8
+  NIX_CFLAGS_COMPILE = with stdenv.lib; (optionals stdenv.cc.isGNU [
+    "-Wno-error=int-in-bool-context"
+    "-Wno-error=class-memaccess"
+    "-Wno-error=restrict"
+    "-Wno-error=format-truncation"
+   ]) ++ optional stdenv.cc.isClang "-Wno-error=null-dereference";
 
   patchPhase = stdenv.lib.optionalString stdenv.isDarwin ''
     substituteInPlace src/LApack.cc --replace "malloc.h" "malloc/malloc.h"