about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorVolth <volth@webmaster.ms>2017-03-23 15:26:37 -0500
committerFranz Pletz <fpletz@fnordicwalking.de>2017-03-25 14:54:16 +0100
commit1cca97cf1864605e5163b298c43b5d2f6b3ff4c1 (patch)
tree21afca3019e67d696ad40588680225ae24175200 /pkgs/development
parenta9172891d964c03a9d833cf0c5cf861ebaad9d35 (diff)
downloadnixlib-1cca97cf1864605e5163b298c43b5d2f6b3ff4c1.tar
nixlib-1cca97cf1864605e5163b298c43b5d2f6b3ff4c1.tar.gz
nixlib-1cca97cf1864605e5163b298c43b5d2f6b3ff4c1.tar.bz2
nixlib-1cca97cf1864605e5163b298c43b5d2f6b3ff4c1.tar.lz
nixlib-1cca97cf1864605e5163b298c43b5d2f6b3ff4c1.tar.xz
nixlib-1cca97cf1864605e5163b298c43b5d2f6b3ff4c1.tar.zst
nixlib-1cca97cf1864605e5163b298c43b5d2f6b3ff4c1.zip
libvirt: 3.0.0 -> 3.1.0
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/libraries/libvirt/default.nix19
1 files changed, 11 insertions, 8 deletions
diff --git a/pkgs/development/libraries/libvirt/default.nix b/pkgs/development/libraries/libvirt/default.nix
index 5fcdd153c99c..2c5d6350315b 100644
--- a/pkgs/development/libraries/libvirt/default.nix
+++ b/pkgs/development/libraries/libvirt/default.nix
@@ -6,6 +6,9 @@
 , dnsmasq, libnl, libpcap, libxslt, xhtml1, numad, numactl, perlPackages
 , curl, libiconv, gmp, xen, zfs
 }:
+
+with stdenv.lib;
+
 # if you update, also bump pythonPackages.libvirt or it will break
 stdenv.mkDerivation rec {
   name = "libvirt-${version}";
@@ -23,14 +26,14 @@ stdenv.mkDerivation rec {
     libxml2 gnutls perl python2 readline
     gettext libtasn1 libgcrypt yajl
     libxslt xhtml1 perlPackages.XMLXPath curl libpcap
-  ] ++ stdenv.lib.optionals stdenv.isLinux [
+  ] ++ optionals stdenv.isLinux [
     libpciaccess devicemapper lvm2 utillinux systemd libcap_ng
     libnl numad numactl xen zfs
-  ] ++ stdenv.lib.optionals stdenv.isDarwin [
+  ] ++ optionals stdenv.isDarwin [
      libiconv gmp
   ];
 
-  preConfigure = stdenv.lib.optionalString stdenv.isLinux ''
+  preConfigure = optionalString stdenv.isLinux ''
     PATH=${stdenv.lib.makeBinPath [ iproute iptables ebtables lvm2 systemd ]}:$PATH
     substituteInPlace configure \
       --replace 'as_dummy="/bin:/usr/bin:/usr/sbin"' 'as_dummy="${numad}/bin"'
@@ -48,13 +51,13 @@ stdenv.mkDerivation rec {
     "--with-test"
     "--with-esx"
     "--with-remote"
-  ] ++ stdenv.lib.optionals stdenv.isLinux [
+  ] ++ optionals stdenv.isLinux [
     "--with-numad"
     "--with-macvtap"
     "--with-virtualport"
     "--with-init-script=redhat"
     "--with-storage-zfs"
-  ] ++ stdenv.lib.optionals stdenv.isDarwin [
+  ] ++ optionals stdenv.isDarwin [
     "--with-init-script=none"
   ];
 
@@ -67,16 +70,16 @@ stdenv.mkDerivation rec {
     sed -i 's/ON_SHUTDOWN=suspend/ON_SHUTDOWN=''${ON_SHUTDOWN:-suspend}/' $out/libexec/libvirt-guests.sh
     substituteInPlace $out/libexec/libvirt-guests.sh \
       --replace "$out/bin" "${gettext}/bin"
-  '' + stdenv.lib.optionalString stdenv.isLinux ''
+  '' + optionalString stdenv.isLinux ''
     wrapProgram $out/sbin/libvirtd \
-      --prefix PATH : ${stdenv.lib.makeBinPath [ iptables iproute pmutils numad numactl ]}
+      --prefix PATH : ${makeBinPath [ iptables iproute pmutils numad numactl ]}
   '';
 
   enableParallelBuilding = true;
 
   NIX_CFLAGS_COMPILE = "-fno-stack-protector";
 
-  meta = with stdenv.lib; {
+  meta = {
     homepage = http://libvirt.org/;
     repositories.git = git://libvirt.org/libvirt.git;
     description = ''