about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorWilliButz <wbutz@cyberfnord.de>2018-04-18 23:48:11 +0200
committerRobin Gloster <mail@glob.in>2018-04-19 00:36:29 +0200
commit1c09a7cd4f2caa61f0ac9b2cf7ecaae78c4ad93d (patch)
treea3722a952c6a787b7994e9b2e901c918dacd6198 /pkgs/development
parentff3e3fb39dea682574f3dde798af96001543d104 (diff)
downloadnixlib-1c09a7cd4f2caa61f0ac9b2cf7ecaae78c4ad93d.tar
nixlib-1c09a7cd4f2caa61f0ac9b2cf7ecaae78c4ad93d.tar.gz
nixlib-1c09a7cd4f2caa61f0ac9b2cf7ecaae78c4ad93d.tar.bz2
nixlib-1c09a7cd4f2caa61f0ac9b2cf7ecaae78c4ad93d.tar.lz
nixlib-1c09a7cd4f2caa61f0ac9b2cf7ecaae78c4ad93d.tar.xz
nixlib-1c09a7cd4f2caa61f0ac9b2cf7ecaae78c4ad93d.tar.zst
nixlib-1c09a7cd4f2caa61f0ac9b2cf7ecaae78c4ad93d.zip
wt: 3.3.9 -> 3.3.10, 4.0.2 -> 4.0.3
This also removes the boost version pinning which became unnecessary
and uses the updated github username for the source repo.
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/libraries/wt/default.nix16
1 files changed, 7 insertions, 9 deletions
diff --git a/pkgs/development/libraries/wt/default.nix b/pkgs/development/libraries/wt/default.nix
index 37819c2a98e3..99f73add795a 100644
--- a/pkgs/development/libraries/wt/default.nix
+++ b/pkgs/development/libraries/wt/default.nix
@@ -1,4 +1,4 @@
-{ stdenv, fetchFromGitHub, cmake, boost165, pkgconfig, doxygen, qt48Full, libharu
+{ stdenv, fetchFromGitHub, cmake, boost, pkgconfig, doxygen, qt48Full, libharu
 , pango, fcgi, firebird, mysql, postgresql, graphicsmagick, glew, openssl
 , pcre
 }:
@@ -10,7 +10,7 @@ let
       name = "wt-${version}";
 
       src = fetchFromGitHub {
-        owner = "kdeforche";
+        owner = "emweb";
         repo = "wt";
         rev = version;
         inherit sha256;
@@ -20,7 +20,7 @@ let
 
       nativeBuildInputs = [ pkgconfig ];
       buildInputs = [
-        cmake boost165 doxygen qt48Full libharu
+        cmake boost doxygen qt48Full libharu
         pango fcgi firebird mysql.connector-c postgresql graphicsmagick glew
         openssl pcre
       ];
@@ -43,14 +43,12 @@ let
     };
 in {
   wt3 = generic {
-    # with the next version update the version pinning of boost should be omitted
-    version = "3.3.9";
-    sha256 = "1mkflhvzzzxkc5yzvr6nk34j0ldpwxjxb6n7xml59h3j3px3ixjm";
+    version = "3.3.10";
+    sha256 = "1y25mhghgbgjgycpny0x4z95xn98q0wraab1c5gkwnay097bgwdy";
   };
 
   wt4 = generic {
-    # with the next version update the version pinning of boost should be omitted
-    version = "4.0.2";
-    sha256 = "0r729gjd1sy0pcmir2r7ga33mp5cr5b4gvf44852q65hw2577w1x";
+    version = "4.0.3";
+    sha256 = "01xch5dkpcanwhr515236wa9mdmnq2a2j13dn7smyhwzqgbpknsg";
   };
 }