about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorFrederik Rietdijk <freddyrietdijk@fridh.nl>2018-06-23 13:53:29 +0200
committerGitHub <noreply@github.com>2018-06-23 13:53:29 +0200
commit1106d872ae8102156f14959bf7b96fcf240ea88c (patch)
tree964c447c598bc8223fd6b93a3c2637f954f2ec15 /pkgs/development
parent14b28269b3db1f2b6d3271bba2cdb198724d8e91 (diff)
parent1dcee7a1622ec79885958930b7e1b2051c7460aa (diff)
downloadnixlib-1106d872ae8102156f14959bf7b96fcf240ea88c.tar
nixlib-1106d872ae8102156f14959bf7b96fcf240ea88c.tar.gz
nixlib-1106d872ae8102156f14959bf7b96fcf240ea88c.tar.bz2
nixlib-1106d872ae8102156f14959bf7b96fcf240ea88c.tar.lz
nixlib-1106d872ae8102156f14959bf7b96fcf240ea88c.tar.xz
nixlib-1106d872ae8102156f14959bf7b96fcf240ea88c.tar.zst
nixlib-1106d872ae8102156f14959bf7b96fcf240ea88c.zip
Merge pull request #42421 from bandresen/python-periphery
pythonPackages.python-periphery: init at 1.1.1
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/python-modules/python-periphery/default.nix21
1 files changed, 21 insertions, 0 deletions
diff --git a/pkgs/development/python-modules/python-periphery/default.nix b/pkgs/development/python-modules/python-periphery/default.nix
new file mode 100644
index 000000000000..b2b103858cce
--- /dev/null
+++ b/pkgs/development/python-modules/python-periphery/default.nix
@@ -0,0 +1,21 @@
+{ lib, buildPythonPackage, fetchPypi }:
+
+buildPythonPackage rec {
+  pname = "python-periphery";
+  version = "1.1.1";
+
+  src = fetchPypi {
+    inherit pname version;
+    sha256 = "fe8f351934edce72cd919b4eb070878ebff551db5e21aea61e0f446101f0a79f";
+  };
+
+  # Some tests require physical probing and additional physical setup
+  doCheck = false;
+
+  meta = {
+    homepage = https://github.com/vsergeev/python-periphery;
+    description = "Linux Peripheral I/O (GPIO, LED, PWM, SPI, I2C, MMIO, Serial) with Python 2 & 3";
+    license = lib.licenses.mit;
+    maintainers = with lib.maintainers; [ bandresen ];
+  };
+}