about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorJonathan Ringer <jonringer117@gmail.com>2020-03-30 19:21:12 -0700
committerJon <jonringer@users.noreply.github.com>2020-04-15 21:19:26 -0700
commit0eec28560f46a9032657f18123a560f19da47e58 (patch)
treeab7e758da9192cb66c5096ef183231040cfae202 /pkgs/development
parent95e007d69fe4902dbfb85091348a129d7b67a8e1 (diff)
downloadnixlib-0eec28560f46a9032657f18123a560f19da47e58.tar
nixlib-0eec28560f46a9032657f18123a560f19da47e58.tar.gz
nixlib-0eec28560f46a9032657f18123a560f19da47e58.tar.bz2
nixlib-0eec28560f46a9032657f18123a560f19da47e58.tar.lz
nixlib-0eec28560f46a9032657f18123a560f19da47e58.tar.xz
nixlib-0eec28560f46a9032657f18123a560f19da47e58.tar.zst
nixlib-0eec28560f46a9032657f18123a560f19da47e58.zip
python3Packages.ibis: 1.2.0 -> 1.3.0, fix tests
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/python-modules/ibis-framework/default.nix26
1 files changed, 13 insertions, 13 deletions
diff --git a/pkgs/development/python-modules/ibis-framework/default.nix b/pkgs/development/python-modules/ibis-framework/default.nix
index e4ce6425f261..2381f52614e1 100644
--- a/pkgs/development/python-modules/ibis-framework/default.nix
+++ b/pkgs/development/python-modules/ibis-framework/default.nix
@@ -1,29 +1,26 @@
-{ lib
-, buildPythonPackage
-, fetchPypi
+{ lib, buildPythonPackage, fetchPypi, isPy27, pythonAtLeast
+, graphviz
 , multipledispatch
 , numpy
 , pandas
+, pyarrow
+, pytest
 , pytz
 , regex
-, toolz
-, isPy27
-, pytest
-, sqlalchemy
 , requests
+, sqlalchemy
 , tables
-, pyarrow
-, graphviz
+, toolz
 }:
 
 buildPythonPackage rec {
   pname = "ibis-framework";
-  version = "1.2.0";
-  disabled = isPy27;
+  version = "1.3.0";
+  disabled = isPy27 || pythonAtLeast "3.8";
 
   src = fetchPypi {
     inherit pname version;
-    sha256 = "3a0b79dae6924be0a79669c881a9a1d4817997ad2f81a0f3b1cd03d70aebb071";
+    sha256 = "1my94a11jzg1hv6ln8wxklbqrg6z5l2l77vr89aq0829yyxacmv7";
   };
 
   propagatedBuildInputs = [
@@ -44,8 +41,11 @@ buildPythonPackage rec {
     pytest
   ];
 
+  # ignore tests which require test dataset, or frameworks not available
   checkPhase = ''
-    pytest ibis
+    pytest ibis \
+      --ignore=ibis/tests/all \
+      --ignore=ibis/{sql,spark}
   '';
 
   meta = with lib; {