about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorRadik Islamov <vizid1337@gmail.com>2024-03-21 23:54:57 +0500
committerRadik Islamov <vizid1337@gmail.com>2024-03-21 23:54:57 +0500
commit0ea5d36e3fafc08884f2401f210066cc7e554db2 (patch)
treed27d96ac438de598b8809907a2dba084c2988d49 /pkgs/development
parent34cfa58e7918c8f5a191eb4d191481653ff65e00 (diff)
downloadnixlib-0ea5d36e3fafc08884f2401f210066cc7e554db2.tar
nixlib-0ea5d36e3fafc08884f2401f210066cc7e554db2.tar.gz
nixlib-0ea5d36e3fafc08884f2401f210066cc7e554db2.tar.bz2
nixlib-0ea5d36e3fafc08884f2401f210066cc7e554db2.tar.lz
nixlib-0ea5d36e3fafc08884f2401f210066cc7e554db2.tar.xz
nixlib-0ea5d36e3fafc08884f2401f210066cc7e554db2.tar.zst
nixlib-0ea5d36e3fafc08884f2401f210066cc7e554db2.zip
python311Packages.wunsen: init at 0.0.3
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/python-modules/wunsen/default.nix52
1 files changed, 52 insertions, 0 deletions
diff --git a/pkgs/development/python-modules/wunsen/default.nix b/pkgs/development/python-modules/wunsen/default.nix
new file mode 100644
index 000000000000..5fc6ea2d3803
--- /dev/null
+++ b/pkgs/development/python-modules/wunsen/default.nix
@@ -0,0 +1,52 @@
+{ lib
+, buildPythonPackage
+, fetchFromGitHub
+
+, pythonOlder
+
+, unittestCheckHook
+
+, hatchling
+
+, khanaa
+}:
+
+buildPythonPackage rec {
+  pname = "wunsen";
+  version = "0.0.3";
+  pyproject = true;
+
+  disabled = pythonOlder "3.7";
+
+  src = fetchFromGitHub {
+    owner = "cakimpei";
+    repo = "wunsen";
+    rev = "refs/tags/v${version}";
+    hash = "sha256-lMEhtcWG+S3vAz+Y/qDxhaZslsO0pbs5xUn5QgZNs2U=";
+  };
+
+  build-system = [
+    hatchling
+  ];
+
+  dependencies = [
+    khanaa
+  ];
+
+  nativeCheckInputs = [
+    unittestCheckHook
+  ];
+
+  unittestFlagsArray = [ "-s" "tests" ];
+
+  pythonImportsCheck = [ "wunsen" ];
+
+  meta = with lib;
+    {
+      description = "Transliterate/transcribe other languages into Thai Topics";
+      homepage = "https://github.com/cakimpei/wunsen";
+      changelog = "https://github.com/cakimpei/wunsen/releases/tag/v${version}";
+      license = licenses.mit;
+      maintainers = with maintainers; [ vizid ];
+    };
+}