about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorFrederik Rietdijk <fridh@fridh.nl>2019-01-03 10:05:50 +0100
committerFrederik Rietdijk <fridh@fridh.nl>2019-01-04 10:45:22 +0100
commit0a2caa41fe0da9e5c36f47994594650f00e1d111 (patch)
treee7b9a6f88de8a8c3ee71ed65b2d9257836f9a3a0 /pkgs/development
parentf665828fa374580f4b2fd725761d23e18f55e526 (diff)
downloadnixlib-0a2caa41fe0da9e5c36f47994594650f00e1d111.tar
nixlib-0a2caa41fe0da9e5c36f47994594650f00e1d111.tar.gz
nixlib-0a2caa41fe0da9e5c36f47994594650f00e1d111.tar.bz2
nixlib-0a2caa41fe0da9e5c36f47994594650f00e1d111.tar.lz
nixlib-0a2caa41fe0da9e5c36f47994594650f00e1d111.tar.xz
nixlib-0a2caa41fe0da9e5c36f47994594650f00e1d111.tar.zst
nixlib-0a2caa41fe0da9e5c36f47994594650f00e1d111.zip
Python: drop `python.majorVersion`
Drop `python.majorVersion`. For Python language version, use `python.pythonVersion`.
For implementation version, use `python.sourceVersion`.

Some expressions were broken. Those that were identified were fixed.

fixup major
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/interpreters/python/default.nix2
-rw-r--r--pkgs/development/libraries/physics/geant4/g4py/default.nix2
-rw-r--r--pkgs/development/python-modules/tensorflow/bin.nix2
3 files changed, 2 insertions, 4 deletions
diff --git a/pkgs/development/interpreters/python/default.nix b/pkgs/development/interpreters/python/default.nix
index 786ae76c1dd0..b45dc55390c9 100644
--- a/pkgs/development/interpreters/python/default.nix
+++ b/pkgs/development/interpreters/python/default.nix
@@ -39,8 +39,6 @@ with pkgs;
         pythonAtLeast = lib.versionAtLeast pythonVersion;
         pythonOlder = lib.versionOlder pythonVersion;
         inherit pythonForBuild;
-
-        majorVersion = pythonVersion; # Backwards compatibility. Should be dropped.
   };
 
 in {
diff --git a/pkgs/development/libraries/physics/geant4/g4py/default.nix b/pkgs/development/libraries/physics/geant4/g4py/default.nix
index 551d61af3ada..f28f0fd64203 100644
--- a/pkgs/development/libraries/physics/geant4/g4py/default.nix
+++ b/pkgs/development/libraries/physics/geant4/g4py/default.nix
@@ -28,7 +28,7 @@ stdenv.mkDerivation rec {
   preConfigure = ''
     # Fix for boost 1.67+
     substituteInPlace CMakeLists.txt \
-    --replace "find_package(Boost)" "find_package(Boost 1.40 REQUIRED COMPONENTS python${builtins.replaceStrings ["."] [""] python.majorVersion})"
+    --replace "find_package(Boost)" "find_package(Boost 1.40 REQUIRED COMPONENTS python${builtins.replaceStrings ["."] [""] python.pythonVersion})"
     for f in `find . -name CMakeLists.txt`; do
       substituteInPlace "$f" \
         --replace "boost_python" "\''${Boost_LIBRARIES}"
diff --git a/pkgs/development/python-modules/tensorflow/bin.nix b/pkgs/development/python-modules/tensorflow/bin.nix
index b925b74e03b5..90f8c9e6e302 100644
--- a/pkgs/development/python-modules/tensorflow/bin.nix
+++ b/pkgs/development/python-modules/tensorflow/bin.nix
@@ -45,7 +45,7 @@ in buildPythonPackage rec {
   format = "wheel";
 
   src = let
-    pyVerNoDot = lib.strings.stringAsChars (x: if x == "." then "" else x) "${python.majorVersion}";
+    pyVerNoDot = lib.strings.stringAsChars (x: if x == "." then "" else x) "${python.pythonVersion}";
     pyver = if stdenv.isDarwin then builtins.substring 0 1 pyVerNoDot else pyVerNoDot;
     platform = if stdenv.isDarwin then "mac" else "linux";
     unit = if cudaSupport then "gpu" else "cpu";