about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorJörg Thalheim <Mic92@users.noreply.github.com>2017-03-26 11:45:37 +0200
committerGitHub <noreply@github.com>2017-03-26 11:45:37 +0200
commit09c91f5fea73746c2ea85b37834e7ec450923d18 (patch)
tree2b85f4c9b1cd4c39157fa7e5712c7a45c4847152 /pkgs/development
parente0fd894d88c0829db92ff490c2717f12364e986f (diff)
parent03ddb417c3f64cb59ca2b0c4833db40b1313bf46 (diff)
downloadnixlib-09c91f5fea73746c2ea85b37834e7ec450923d18.tar
nixlib-09c91f5fea73746c2ea85b37834e7ec450923d18.tar.gz
nixlib-09c91f5fea73746c2ea85b37834e7ec450923d18.tar.bz2
nixlib-09c91f5fea73746c2ea85b37834e7ec450923d18.tar.lz
nixlib-09c91f5fea73746c2ea85b37834e7ec450923d18.tar.xz
nixlib-09c91f5fea73746c2ea85b37834e7ec450923d18.tar.zst
nixlib-09c91f5fea73746c2ea85b37834e7ec450923d18.zip
Merge pull request #24002 from deepfire/vogl
vogl:  init at 2016-05-13
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/tools/vogl/default.nix47
1 files changed, 47 insertions, 0 deletions
diff --git a/pkgs/development/tools/vogl/default.nix b/pkgs/development/tools/vogl/default.nix
new file mode 100644
index 000000000000..f3967b0d9235
--- /dev/null
+++ b/pkgs/development/tools/vogl/default.nix
@@ -0,0 +1,47 @@
+{ fetchFromGitHub, stdenv
+, cmake, git, pkgconfig, wget, zip
+, makeQtWrapper, qtbase, qtx11extras
+, libdwarf, libjpeg_turbo, libunwind, lzma, tinyxml, libX11
+, SDL2, SDL2_gfx, SDL2_image, SDL2_ttf
+, freeglut, mesa, mesa_glu
+}:
+stdenv.mkDerivation rec {
+  name = "vogl-${version}";
+  version = "2016-05-13";
+
+  src = fetchFromGitHub {
+    owner  = "deepfire";
+    repo   = "vogl";
+    rev    = "cbc5f1853e294b363f16c4e00b3e0c49dbf74559";
+    sha256 = "17gwd73x3lnqv6ccqs48pzqwbzjhbn41c0x0l5zzirhiirb3yh0n";
+  };
+
+  nativeBuildInputs = [
+    cmake makeQtWrapper pkgconfig
+  ];
+
+  buildInputs = [
+    git wget zip
+    qtbase qtx11extras
+    libdwarf libjpeg_turbo libunwind lzma tinyxml libX11
+    SDL2 SDL2_gfx SDL2_image SDL2_ttf
+    freeglut mesa mesa_glu
+  ];
+
+  enableParallelBuilding = true;
+
+  dontUseCmakeBuildDir = true;
+  preConfigure = ''
+    cmakeDir=$PWD
+    mkdir -p vogl/vogl_build/release64 && cd $_
+  '';
+  cmakeFlags = '' -DCMAKE_VERBOSE=On -DCMAKE_BUILD_TYPE=Release -DBUILD_X64=On'';
+
+  meta = with stdenv.lib; {
+    description = "OpenGL capture / playback debugger.";
+    homepage = https://github.com/ValveSoftware/vogl;
+    license = licenses.mit;
+    maintainers = [ maintainers.deepfire ];
+    platforms = [ "x86_64-linux" "i686-linux" ];
+  };
+}