about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2010-03-04 11:10:44 +0000
committerLudovic Courtès <ludo@gnu.org>2010-03-04 11:10:44 +0000
commit07356746efd9f9de0937fc127c3d199e60f91f7d (patch)
tree8ba23b0f27004b24cbb4138370818478c12ef449 /pkgs/development
parent888d6711dacd029bade5a0d64b74e12cfc4cfea0 (diff)
downloadnixlib-07356746efd9f9de0937fc127c3d199e60f91f7d.tar
nixlib-07356746efd9f9de0937fc127c3d199e60f91f7d.tar.gz
nixlib-07356746efd9f9de0937fc127c3d199e60f91f7d.tar.bz2
nixlib-07356746efd9f9de0937fc127c3d199e60f91f7d.tar.lz
nixlib-07356746efd9f9de0937fc127c3d199e60f91f7d.tar.xz
nixlib-07356746efd9f9de0937fc127c3d199e60f91f7d.tar.zst
nixlib-07356746efd9f9de0937fc127c3d199e60f91f7d.zip
Add GNU cppi.
svn path=/nixpkgs/trunk/; revision=20363
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/tools/misc/cppi/default.nix33
1 files changed, 33 insertions, 0 deletions
diff --git a/pkgs/development/tools/misc/cppi/default.nix b/pkgs/development/tools/misc/cppi/default.nix
new file mode 100644
index 000000000000..78bcb2226a3a
--- /dev/null
+++ b/pkgs/development/tools/misc/cppi/default.nix
@@ -0,0 +1,33 @@
+{ fetchurl, xz, stdenv }:
+
+stdenv.mkDerivation rec {
+  name = "cppi-1.14";
+
+  src = fetchurl {
+    url = "mirror://gnu/cppi/${name}.tar.xz";
+    sha256 = "0n7388f5z4nnyh17rnj7h0kvml3x2mba6a5km87k2bvm5v4mcrfc";
+  };
+
+  buildInputs = [ xz ];
+
+  doCheck = true;
+
+  meta = {
+    homepage = http://savannah.gnu.org/projects/cppi/;
+
+    description = "GNU cppi, a cpp directive indenter";
+
+    longDescription =
+      '' GNU cppi indents C preprocessor directives to reflect their nesting
+         and ensure that there is exactly one space character between each #if,
+         #elif, #define directive and the following token.  The number of
+         spaces between the `#' and the following directive must correspond
+         to the level of nesting of that directive.
+      '';
+
+    license = "GPLv3+";
+
+    maintainers = [ stdenv.lib.maintainers.ludo ];
+    platforms = stdenv.lib.platforms.all;
+  };
+}