about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorChristian S <ch.schmidbauer+git@gmail.com>2018-10-31 19:00:25 +0100
committerc0bw3b <c0bw3b@users.noreply.github.com>2018-11-15 21:22:19 +0100
commit064f35fad39575254a393ce5272ab131bd3e4374 (patch)
treea6158676008b2bbcec87738cd0d2d9efd8902f68 /pkgs/development
parent9e39329e1f96ad0a6dcf12dba6e409a88c3024a6 (diff)
downloadnixlib-064f35fad39575254a393ce5272ab131bd3e4374.tar
nixlib-064f35fad39575254a393ce5272ab131bd3e4374.tar.gz
nixlib-064f35fad39575254a393ce5272ab131bd3e4374.tar.bz2
nixlib-064f35fad39575254a393ce5272ab131bd3e4374.tar.lz
nixlib-064f35fad39575254a393ce5272ab131bd3e4374.tar.xz
nixlib-064f35fad39575254a393ce5272ab131bd3e4374.tar.zst
nixlib-064f35fad39575254a393ce5272ab131bd3e4374.zip
x265: 2.7 -> 2.9
Encoder enhancements, AVX-512 support, ...

x265: fix linking issue on aarch64
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/libraries/x265/default.nix21
1 files changed, 15 insertions, 6 deletions
diff --git a/pkgs/development/libraries/x265/default.nix b/pkgs/development/libraries/x265/default.nix
index d11a93254bfb..4212687a02ac 100644
--- a/pkgs/development/libraries/x265/default.nix
+++ b/pkgs/development/libraries/x265/default.nix
@@ -1,4 +1,4 @@
-{ stdenv, fetchurl, cmake, yasm
+{ stdenv, fetchurl, fetchpatch, cmake, yasm
 , debugSupport ? false # Run-time sanity checks (debugging)
 , highbitdepthSupport ? false # false=8bits per channel, true=10/12bits per channel
 , werrorSupport ? false # Warnings as errors
@@ -16,19 +16,28 @@ in
 
 stdenv.mkDerivation rec {
   name = "x265-${version}";
-  version = "2.7";
+  version = "2.9";
 
   src = fetchurl {
     urls = [
-      "http://get.videolan.org/x265/x265_${version}.tar.gz"
-      "https://github.com/videolan/x265/archive/${version}.tar.gz"
+      "https://get.videolan.org/x265/x265_${version}.tar.gz"
+      "ftp://ftp.videolan.org/pub/videolan/x265/x265_${version}.tar.gz"
     ];
-    sha256 = "18llni1m8kfvdwy5bp950z6gyd0nijmvi3hzd6gd8vpy5yk5zrym";
+    sha256 = "090hp4216isis8q5gb7bwzia8rfyzni54z21jnwm97x3hiy6ibpb";
   };
 
   enableParallelBuilding = true;
 
-  patchPhase = ''
+  patches = [
+    # Fix issue #442 (linking issue on non-x86 platforms)
+    # Applies on v2.9 only, this should be removed at next update
+    (fetchpatch {
+      url = "https://bitbucket.org/multicoreware/x265/commits/471726d3a0462739ff8e3518eb1a1e8a01de4e8d/raw";
+      sha256 = "0mj8lb8ng8lrhzjavap06vjhqf6j0r3sn76c6rhs3012f86lv928";
+    })
+  ];
+
+  postPatch = ''
     sed -i 's/unknown/${version}/g' source/cmake/version.cmake
   '';