about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorworldofpeace <worldofpeace@protonmail.ch>2019-10-18 21:42:22 +0000
committerGitHub <noreply@github.com>2019-10-18 21:42:22 +0000
commit020e1b0c8e4f8d370fd44d2197b8d06fc7b16182 (patch)
tree1b09240fc1a8f13a4b0f48a0c47f9e9ec530fe79 /pkgs/development
parent8b0f365582ee53628788b864b946965e6ccf3a7e (diff)
parent67b8f4e0a76dbc54f5310167d15a8edc8e663ae5 (diff)
downloadnixlib-020e1b0c8e4f8d370fd44d2197b8d06fc7b16182.tar
nixlib-020e1b0c8e4f8d370fd44d2197b8d06fc7b16182.tar.gz
nixlib-020e1b0c8e4f8d370fd44d2197b8d06fc7b16182.tar.bz2
nixlib-020e1b0c8e4f8d370fd44d2197b8d06fc7b16182.tar.lz
nixlib-020e1b0c8e4f8d370fd44d2197b8d06fc7b16182.tar.xz
nixlib-020e1b0c8e4f8d370fd44d2197b8d06fc7b16182.tar.zst
nixlib-020e1b0c8e4f8d370fd44d2197b8d06fc7b16182.zip
Merge pull request #71334 from edef1c/git-series
Clean up git-series packaging, use OpenSSL 1.1
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/tools/git-series/default.nix34
1 files changed, 18 insertions, 16 deletions
diff --git a/pkgs/development/tools/git-series/default.nix b/pkgs/development/tools/git-series/default.nix
index 5faceca57166..d2bc539860b3 100644
--- a/pkgs/development/tools/git-series/default.nix
+++ b/pkgs/development/tools/git-series/default.nix
@@ -1,4 +1,4 @@
-{ stdenv, fetchFromGitHub, fetchpatch, rustPlatform, openssl_1_0_2, cmake, perl, pkgconfig, zlib }:
+{ stdenv, fetchFromGitHub, fetchpatch, rustPlatform, openssl, cmake, perl, pkgconfig, zlib, curl, libgit2 }:
 
 with rustPlatform;
 
@@ -13,21 +13,23 @@ buildRustPackage rec {
     sha256 = "07mgq5h6r1gf3jflbv2khcz32bdazw7z1s8xcsafdarnm13ps014";
   };
 
-  cargoSha256 = "07b25pcndhwvpwa5khdh8y1fl44hdv6ff2pfj1mjc0wchbspqm6q";
-
-  cargoDepsHook = ''
-    (
-      cd */
-      # see https://github.com/git-series/git-series/pull/56
-      patch -p1 < ${fetchpatch {
-        url = "https://github.com/Mic92/git-series/commit/3aa30a47d74ebf90b444dccdf8c153f07f119483.patch";
-        sha256 = "06v8br9skvy75kcw2zgbswxyk82sqzc8smkbqpzmivxlc2i9rnh0";
-      }}
-    )
-  '';
-
+  cargoSha256 = "09y4fvv279cm5sgbpmskascb7rrwqgya5w5wkpz1bgx6pzw3mc7y";
+
+  cargoPatches = [
+    (fetchpatch {
+      url = "https://github.com/Mic92/git-series/commit/3aa30a47d74ebf90b444dccdf8c153f07f119483.patch";
+      sha256 = "06v8br9skvy75kcw2zgbswxyk82sqzc8smkbqpzmivxlc2i9rnh0";
+    })
+    # Update Cargo.lock to allow using OpenSSL 1.1
+    (fetchpatch {
+      url = "https://github.com/edef1c/git-series/commit/11fe70ffcc18200e5f2a159c36aab070e8ff4228.patch";
+      sha256 = "0clwllf9mrhq86dhzyyhkw1q2ggpgqpw7s05dvp3gj9zhfsyya4s";
+    })
+  ];
+
+  LIBGIT2_SYS_USE_PKG_CONFIG = true;
   nativeBuildInputs = [ cmake pkgconfig perl ];
-  buildInputs = [ openssl_1_0_2 zlib ];
+  buildInputs = [ openssl zlib curl libgit2 ];
 
   postBuild = ''
     install -D "$src/git-series.1" "$out/man/man1/git-series.1"
@@ -43,6 +45,6 @@ buildRustPackage rec {
     homepage = https://github.com/git-series/git-series;
 
     license = licenses.mit;
-    maintainers = [ maintainers.vmandela ];
+    maintainers = with maintainers; [ edef vmandela ];
   };
 }