about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorzimbatm <zimbatm@zimbatm.com>2019-11-03 12:19:18 +0000
committerGitHub <noreply@github.com>2019-11-03 12:19:18 +0000
commit01f6d4d36f4eda1d8137cd4e996a3d635bd28801 (patch)
treee94d2cbba213b3503427f92ec97da080f52c8f15 /pkgs/development
parent561b40dacbf0ca4dd1bddffd65c3ac09b12b281a (diff)
parente4c372445fb2fa688a4d9923d4b9fbfd8a1c322f (diff)
downloadnixlib-01f6d4d36f4eda1d8137cd4e996a3d635bd28801.tar
nixlib-01f6d4d36f4eda1d8137cd4e996a3d635bd28801.tar.gz
nixlib-01f6d4d36f4eda1d8137cd4e996a3d635bd28801.tar.bz2
nixlib-01f6d4d36f4eda1d8137cd4e996a3d635bd28801.tar.lz
nixlib-01f6d4d36f4eda1d8137cd4e996a3d635bd28801.tar.xz
nixlib-01f6d4d36f4eda1d8137cd4e996a3d635bd28801.tar.zst
nixlib-01f6d4d36f4eda1d8137cd4e996a3d635bd28801.zip
Merge pull request #72419 from WilliButz/rubyPackages/remove-global-v8-pinning
rubyPackages: remove global v8 pinning
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/libraries/v8/3.14.nix2
-rw-r--r--pkgs/development/libraries/v8/3.16.14.nix81
-rw-r--r--pkgs/development/ruby-modules/gem-config/default.nix12
-rw-r--r--pkgs/development/ruby-modules/with-packages/Gemfile1
4 files changed, 2 insertions, 94 deletions
diff --git a/pkgs/development/libraries/v8/3.14.nix b/pkgs/development/libraries/v8/3.14.nix
index 3d36245631be..febadc2d6ac8 100644
--- a/pkgs/development/libraries/v8/3.14.nix
+++ b/pkgs/development/libraries/v8/3.14.nix
@@ -80,7 +80,7 @@ stdenv.mkDerivation {
 
   meta = with stdenv.lib; {
     description = "Google's open source JavaScript engine";
-    platforms = platforms.linux;
+    platforms = [ "x86_64-linux" "i686-linux" ];
     license = licenses.bsd3;
   };
 }
diff --git a/pkgs/development/libraries/v8/3.16.14.nix b/pkgs/development/libraries/v8/3.16.14.nix
deleted file mode 100644
index e134c9ea60f5..000000000000
--- a/pkgs/development/libraries/v8/3.16.14.nix
+++ /dev/null
@@ -1,81 +0,0 @@
-{ stdenv, lib, fetchurl, gyp, readline, python, which, icu, utillinux, cctools }:
-
-assert readline != null;
-
-let
-  arch = if stdenv.isAarch32
-    then (if stdenv.is64bit then "arm64" else "arm")
-    else (if stdenv.is64bit then "x64" else "ia32");
-  armHardFloat = stdenv.isAarch32 && (stdenv.hostPlatform.platform.gcc.float or null) == "hard";
-in
-
-stdenv.mkDerivation rec {
-  pname = "v8";
-  version = "3.16.14.11";
-
-  src = fetchurl {
-    url = "https://commondatastorage.googleapis.com/chromium-browser-official/"
-        + "${pname}-${version}.tar.bz2";
-    sha256 = "1gpf2xvhxfs5ll3m2jlslsx9jfjbmrbz55iq362plflrvf8mbxhj";
-  };
-
-  postPatch = ''
-    sed -i 's/-Werror//' build/standalone.gypi build/common.gypi
-  '';
-
-  configurePhase = stdenv.lib.optionalString stdenv.isDarwin ''
-    export GYP_DEFINES="mac_deployment_target=$MACOSX_DEPLOYMENT_TARGET"
-  '' + ''
-    PYTHONPATH="tools/generate_shim_headers:$PYTHONPATH" \
-      ${gyp}/bin/gyp \
-        -f make \
-        --generator-output="out" \
-        -Dflock_index=0 \
-        -Dv8_enable_i18n_support=1 \
-        -Duse_system_icu=1 \
-        -Dconsole=readline \
-        -Dcomponent=shared_library \
-        -Dv8_target_arch=${arch} \
-        ${lib.optionalString armHardFloat "-Dv8_use_arm_eabi_hardfloat=true"} \
-        --depth=. -Ibuild/standalone.gypi \
-        build/all.gyp
-  '' + stdenv.lib.optionalString stdenv.isDarwin ''
-    sed -i 's@/usr/bin/env python@${python}/bin/python@g' out/gyp-mac-tool
-  '';
-
-  nativeBuildInputs = [ which ];
-  buildInputs = [ readline python icu ]
-                  ++ lib.optional stdenv.isLinux utillinux
-                  ++ lib.optional stdenv.isDarwin cctools;
-
-  NIX_CFLAGS_COMPILE = "-Wno-error -w";
-
-  buildFlags = [
-    "-C out"
-    "builddir=$(CURDIR)/Release"
-    "BUILDTYPE=Release"
-  ];
-
-  enableParallelBuilding = true;
-
-  installPhase = ''
-    install -vD out/Release/d8 "$out/bin/d8"
-    ${if stdenv.isDarwin then ''
-    install -vD out/Release/libv8.dylib "$out/lib/libv8.dylib"
-    '' else ''
-    install -vD out/Release/lib.target/libv8.so "$out/lib/libv8.so"
-    ''}
-    cp -vr include "$out/"
-  '';
-
-  postFixup = if stdenv.isDarwin then ''
-    install_name_tool -change /usr/local/lib/libv8.dylib $out/lib/libv8.dylib $out/bin/d8
-    install_name_tool -id $out/lib/libv8.dylib $out/lib/libv8.dylib
-  '' else null;
-
-  meta = with stdenv.lib; {
-    description = "V8 is Google's open source JavaScript engine";
-    platforms = platforms.linux ++ platforms.darwin;
-    license = licenses.bsd3;
-  };
-}
diff --git a/pkgs/development/ruby-modules/gem-config/default.nix b/pkgs/development/ruby-modules/gem-config/default.nix
index 157e15e375f6..d8c3d484f436 100644
--- a/pkgs/development/ruby-modules/gem-config/default.nix
+++ b/pkgs/development/ruby-modules/gem-config/default.nix
@@ -18,7 +18,7 @@
 # (to make gems behave if necessary).
 
 { lib, fetchurl, writeScript, ruby, kerberos, libxml2, libxslt, python, stdenv, which
-, libiconv, postgresql, v8_3_16_14, clang, sqlite, zlib, imagemagick
+, libiconv, postgresql, v8, clang, sqlite, zlib, imagemagick
 , pkgconfig , ncurses, xapian, gpgme, utillinux, tzdata, icu, libffi
 , cmake, libssh2, openssl, libmysqlclient, darwin, git, perl, pcre, gecode_3, curl
 , msgpack, qt59, libsodium, snappy, libossp_uuid, lxc, libpcap, xorg, gtk2, buildRubyGem
@@ -29,8 +29,6 @@
 }@args:
 
 let
-  v8 = v8_3_16_14;
-
   rainbow_rake = buildRubyGem {
     pname = "rake";
     gemName = "rake";
@@ -567,14 +565,6 @@ in
     buildInputs = [ freetds ];
   };
 
-  therubyracer = attrs: {
-    buildFlags = [
-      "--with-v8-dir=${v8}"
-      "--with-v8-include=${v8}/include"
-      "--with-v8-lib=${v8}/lib"
-    ];
-  };
-
   typhoeus = attrs: {
     buildInputs = [ curl ];
   };
diff --git a/pkgs/development/ruby-modules/with-packages/Gemfile b/pkgs/development/ruby-modules/with-packages/Gemfile
index 0cd04f07b94b..3454ce3df74b 100644
--- a/pkgs/development/ruby-modules/with-packages/Gemfile
+++ b/pkgs/development/ruby-modules/with-packages/Gemfile
@@ -144,7 +144,6 @@ source 'https://rubygems.org' do
   gem 'snappy'
   gem 'sqlite3'
   gem 'taglib-ruby'
-  gem 'therubyracer'
   gem 'thrift'
   gem 'tilt'
   gem 'tiny_tds'