about summary refs log tree commit diff
path: root/pkgs/desktops
diff options
context:
space:
mode:
authorgithub-actions[bot] <41898282+github-actions[bot]@users.noreply.github.com>2023-12-15 00:02:53 +0000
committerGitHub <noreply@github.com>2023-12-15 00:02:53 +0000
commitf97ebb847773097a88aebabd37a3b287a02f25a4 (patch)
tree5237cba491bf44fb0ddda1e9822d472a4df3a69c /pkgs/desktops
parent7be452e197510b95c0091bfb1dde13234dedf4ec (diff)
parentf7d72376c1dd71c6dd7693c22c630416dadfaf1e (diff)
downloadnixlib-f97ebb847773097a88aebabd37a3b287a02f25a4.tar
nixlib-f97ebb847773097a88aebabd37a3b287a02f25a4.tar.gz
nixlib-f97ebb847773097a88aebabd37a3b287a02f25a4.tar.bz2
nixlib-f97ebb847773097a88aebabd37a3b287a02f25a4.tar.lz
nixlib-f97ebb847773097a88aebabd37a3b287a02f25a4.tar.xz
nixlib-f97ebb847773097a88aebabd37a3b287a02f25a4.tar.zst
nixlib-f97ebb847773097a88aebabd37a3b287a02f25a4.zip
Merge staging-next into staging
Diffstat (limited to 'pkgs/desktops')
-rw-r--r--pkgs/desktops/xfce/default.nix2
-rw-r--r--pkgs/desktops/xfce/panel-plugins/xfce4-docklike-plugin/default.nix39
2 files changed, 41 insertions, 0 deletions
diff --git a/pkgs/desktops/xfce/default.nix b/pkgs/desktops/xfce/default.nix
index 4aec72ea334b..94ca82b4388b 100644
--- a/pkgs/desktops/xfce/default.nix
+++ b/pkgs/desktops/xfce/default.nix
@@ -122,6 +122,8 @@ makeScopeWithSplicing' {
 
       xfce4-dockbarx-plugin = callPackage ./panel-plugins/xfce4-dockbarx-plugin { };
 
+      xfce4-docklike-plugin = callPackage ./panel-plugins/xfce4-docklike-plugin { };
+
       xfce4-embed-plugin = callPackage ./panel-plugins/xfce4-embed-plugin { };
 
       xfce4-eyes-plugin = callPackage ./panel-plugins/xfce4-eyes-plugin { };
diff --git a/pkgs/desktops/xfce/panel-plugins/xfce4-docklike-plugin/default.nix b/pkgs/desktops/xfce/panel-plugins/xfce4-docklike-plugin/default.nix
new file mode 100644
index 000000000000..7daabd115d0b
--- /dev/null
+++ b/pkgs/desktops/xfce/panel-plugins/xfce4-docklike-plugin/default.nix
@@ -0,0 +1,39 @@
+{ lib
+, mkXfceDerivation
+, glib
+, gtk3
+, libxfce4ui
+, libxfce4util
+, xfce4-panel
+, xfconf
+, libwnck
+, exo
+}:
+
+mkXfceDerivation {
+  category = "panel-plugins";
+  pname = "xfce4-docklike-plugin";
+  version = "0.4.1";
+  sha256 = "sha256-BKxd2TFEbRHeFy/dC2Wx5ppErsi7d2m7JicFCcZbjTo=";
+
+  buildInputs = [
+    glib
+    gtk3
+    libxfce4ui
+    libxfce4util
+    xfce4-panel
+    xfconf
+    libwnck
+    exo
+  ];
+
+  NIX_CFLAGS_COMPILE = "-I${glib.dev}/include/gio-unix-2.0";
+
+  meta = with lib; {
+    homepage = "https://docs.xfce.org/panel-plugins/xfce4-docklike-plugin/start";
+    description = "A modern, minimalist taskbar for Xfce";
+    license = licenses.gpl3;
+    platforms = platforms.linux;
+    maintainers = with maintainers; [ ] ++ teams.xfce.members;
+  };
+}