about summary refs log tree commit diff
path: root/pkgs/desktops
diff options
context:
space:
mode:
authorvbgl <vbgl@users.noreply.github.com>2017-07-18 21:30:38 +0200
committerGitHub <noreply@github.com>2017-07-18 21:30:38 +0200
commitc17ddcd40cedc56856dcd5fda5483eef4cd00de6 (patch)
treef188d3a0824a6ade316a0e175a0eb38df3c182d0 /pkgs/desktops
parent3c9897431ba199992b674d4d70295b57962232d2 (diff)
parent37452080840cbc94c078210c3784424c90feb645 (diff)
downloadnixlib-c17ddcd40cedc56856dcd5fda5483eef4cd00de6.tar
nixlib-c17ddcd40cedc56856dcd5fda5483eef4cd00de6.tar.gz
nixlib-c17ddcd40cedc56856dcd5fda5483eef4cd00de6.tar.bz2
nixlib-c17ddcd40cedc56856dcd5fda5483eef4cd00de6.tar.lz
nixlib-c17ddcd40cedc56856dcd5fda5483eef4cd00de6.tar.xz
nixlib-c17ddcd40cedc56856dcd5fda5483eef4cd00de6.tar.zst
nixlib-c17ddcd40cedc56856dcd5fda5483eef4cd00de6.zip
Merge pull request #25412 from romildo/fix.efl
{terminology,ephoto,rage,econnman}: wrap libcurl.so in LD_LIBRARY_PATH
Diffstat (limited to 'pkgs/desktops')
-rw-r--r--pkgs/desktops/enlightenment/econnman.nix5
-rw-r--r--pkgs/desktops/enlightenment/ephoto.nix14
-rw-r--r--pkgs/desktops/enlightenment/rage.nix7
-rw-r--r--pkgs/desktops/enlightenment/terminology.nix12
4 files changed, 25 insertions, 13 deletions
diff --git a/pkgs/desktops/enlightenment/econnman.nix b/pkgs/desktops/enlightenment/econnman.nix
index 60e63dc68ed9..7739e2bd09ec 100644
--- a/pkgs/desktops/enlightenment/econnman.nix
+++ b/pkgs/desktops/enlightenment/econnman.nix
@@ -1,4 +1,4 @@
-{ stdenv, fetchurl, pkgconfig, efl, python2Packages, dbus, makeWrapper }:
+{ stdenv, fetchurl, pkgconfig, efl, python2Packages, dbus, curl, makeWrapper }:
 
 stdenv.mkDerivation rec {
   name = "econnman-${version}";
@@ -11,12 +11,13 @@ stdenv.mkDerivation rec {
 
   nativeBuildInputs = [ makeWrapper pkgconfig python2Packages.wrapPython ];
 
-  buildInputs = [ efl python2Packages.python dbus ];
+  buildInputs = [ efl python2Packages.python dbus curl ];
 
   pythonPath = [ python2Packages.pythonefl python2Packages.dbus-python ];
 
   postInstall = ''
     wrapPythonPrograms
+    wrapProgram $out/bin/econnman-bin --prefix LD_LIBRARY_PATH : ${curl.out}/lib
   '';
 
   meta = {
diff --git a/pkgs/desktops/enlightenment/ephoto.nix b/pkgs/desktops/enlightenment/ephoto.nix
index b0606e957922..ee6013dae290 100644
--- a/pkgs/desktops/enlightenment/ephoto.nix
+++ b/pkgs/desktops/enlightenment/ephoto.nix
@@ -1,4 +1,4 @@
-{ stdenv, fetchurl, pkgconfig, efl }:
+{ stdenv, fetchurl, pkgconfig, efl, curl, makeWrapper }:
 
 stdenv.mkDerivation rec {
   name = "ephoto-${version}";
@@ -9,13 +9,9 @@ stdenv.mkDerivation rec {
     sha256 = "0l6zrk22fap6pylmzxwp6nycy8l5wdc7jza890h4zrwmpfag8w31";
   };
 
-  nativeBuildInputs = [
-    pkgconfig
-  ];
+  nativeBuildInputs = [ pkgconfig makeWrapper ];
 
-  buildInputs = [
-    efl
- ];
+  buildInputs = [ efl curl ];
 
   NIX_CFLAGS_COMPILE = [
     "-I${efl}/include/ecore-con-1"
@@ -29,6 +25,10 @@ stdenv.mkDerivation rec {
     "-I${efl}/include/ethumb-client-1"
   ];
 
+  postInstall = ''
+    wrapProgram $out/bin/ephoto --prefix LD_LIBRARY_PATH : ${curl.out}/lib
+  '';
+
   meta = {
     description = "Image viewer and editor written using the Enlightenment Foundation Libraries";
     homepage = http://smhouston.us/ephoto/;
diff --git a/pkgs/desktops/enlightenment/rage.nix b/pkgs/desktops/enlightenment/rage.nix
index a92221050580..4d102b31e3b9 100644
--- a/pkgs/desktops/enlightenment/rage.nix
+++ b/pkgs/desktops/enlightenment/rage.nix
@@ -1,4 +1,4 @@
-{ stdenv, fetchurl, pkgconfig, efl, gst_all_1, wrapGAppsHook }:
+{ stdenv, fetchurl, pkgconfig, efl, gst_all_1, curl, wrapGAppsHook }:
 
 stdenv.mkDerivation rec {
   name = "rage-${version}";
@@ -21,6 +21,7 @@ stdenv.mkDerivation rec {
     gst_all_1.gst-plugins-good
     gst_all_1.gst-plugins-bad
     gst_all_1.gst-libav
+    curl
  ];
 
   NIX_CFLAGS_COMPILE = [
@@ -38,6 +39,10 @@ stdenv.mkDerivation rec {
     "-I${efl}/include/ethumb-client-1"
   ];
 
+  postInstall = ''
+    wrapProgram $out/bin/rage --prefix LD_LIBRARY_PATH : ${curl.out}/lib
+  '';
+
   meta = {
     description = "Video + Audio player along the lines of mplayer";
     homepage = http://enlightenment.org/;
diff --git a/pkgs/desktops/enlightenment/terminology.nix b/pkgs/desktops/enlightenment/terminology.nix
index fc36a7e7a656..5f2db064af24 100644
--- a/pkgs/desktops/enlightenment/terminology.nix
+++ b/pkgs/desktops/enlightenment/terminology.nix
@@ -1,4 +1,4 @@
-{ stdenv, fetchurl, pkgconfig, efl }:
+{ stdenv, fetchurl, pkgconfig, efl, curl, makeWrapper }:
 
 stdenv.mkDerivation rec {
   name = "terminology-${version}";
@@ -9,9 +9,9 @@ stdenv.mkDerivation rec {
     sha256 = "1x4j2q4qqj10ckbka0zaq2r2zm66ff1x791kp8slv1ff7fw45vdz";
   };
 
-  nativeBuildInputs = [ pkgconfig ];
+  nativeBuildInputs = [ pkgconfig makeWrapper ];
 
-  buildInputs = [ efl ];
+  buildInputs = [ efl curl ];
 
   NIX_CFLAGS_COMPILE = [
     "-I${efl}/include/ecore-con-1"
@@ -22,6 +22,12 @@ stdenv.mkDerivation rec {
     "-I${efl}/include/ethumb-1"
   ];
 
+  postInstall = ''
+    for f in $out/bin/*; do
+      wrapProgram $f --prefix LD_LIBRARY_PATH : ${curl.out}/lib
+    done
+  '';
+
   meta = {
     description = "The best terminal emulator written with the EFL";
     homepage = http://enlightenment.org/;