about summary refs log tree commit diff
path: root/pkgs/desktops
diff options
context:
space:
mode:
authorMathijs Kwik <mathijs@bluescreen303.nl>2013-06-26 13:31:21 +0200
committerMathijs Kwik <mathijs@bluescreen303.nl>2013-06-27 21:35:22 +0200
commitbf61d25dacf03502efd0c9e5acc0a18acccafc11 (patch)
tree5eebd055c82dbd9908a8deb55bfccf4f0da1eeb7 /pkgs/desktops
parente78b013fe39522ac51bd6e4a11b8d1e5249e5995 (diff)
downloadnixlib-bf61d25dacf03502efd0c9e5acc0a18acccafc11.tar
nixlib-bf61d25dacf03502efd0c9e5acc0a18acccafc11.tar.gz
nixlib-bf61d25dacf03502efd0c9e5acc0a18acccafc11.tar.bz2
nixlib-bf61d25dacf03502efd0c9e5acc0a18acccafc11.tar.lz
nixlib-bf61d25dacf03502efd0c9e5acc0a18acccafc11.tar.xz
nixlib-bf61d25dacf03502efd0c9e5acc0a18acccafc11.tar.zst
nixlib-bf61d25dacf03502efd0c9e5acc0a18acccafc11.zip
kde 4.10: option to use a libcanberra with gtk support
by default (as it was before), kde depends on a libcanberra with its
gtk dependency removed so a kde system can be gtk-free.

However, both firefox and chromium depend on gtk+ and libcanberra too.
So this leads to 2 versions being installed. this option combats that
by letting the kde use the other libcanberra
Diffstat (limited to 'pkgs/desktops')
-rw-r--r--pkgs/desktops/kde-4.10/kde-runtime.nix13
1 files changed, 11 insertions, 2 deletions
diff --git a/pkgs/desktops/kde-4.10/kde-runtime.nix b/pkgs/desktops/kde-4.10/kde-runtime.nix
index b562d8cadd5c..2282ee57c2c2 100644
--- a/pkgs/desktops/kde-4.10/kde-runtime.nix
+++ b/pkgs/desktops/kde-4.10/kde-runtime.nix
@@ -1,12 +1,21 @@
 { kde, kdelibs, shared_desktop_ontologies, bzip2, libssh, exiv2, attica
 , libcanberra, virtuoso, samba, libjpeg, ntrack, pkgconfig, qca2, xz, pulseaudio
-, networkmanager, kactivities, kdepimlibs, openexr, ilmbase
+, networkmanager, kactivities, kdepimlibs, openexr, ilmbase, config
 }:
 
+let libcanberraWithoutGTK = if (config ? kde_runtime && config.kde_runtime ? libcanberraWithoutGTK)
+                            then config.kde_runtime.libcanberraWithoutGTK
+                            else true;
+
+    canberra = if libcanberraWithoutGTK
+               then libcanberra.override { gtk = null; }
+               else libcanberra;
+in
+
 kde {
   buildInputs = [
     kdelibs attica xz bzip2 libssh libjpeg exiv2 ntrack
-    qca2 samba (libcanberra.override { gtk = null; }) pulseaudio
+    qca2 samba canberra pulseaudio
     networkmanager kactivities kdepimlibs openexr
 #todo: add openslp
   ];