about summary refs log tree commit diff
path: root/pkgs/desktops
diff options
context:
space:
mode:
authorThomas Tuegel <ttuegel@mailbox.org>2017-05-16 10:56:41 -0500
committerThomas Tuegel <ttuegel@mailbox.org>2017-06-18 08:43:39 -0500
commitbe7b7d908f82e8ab16c43ffd0e240addd6f4018a (patch)
tree81d875bcec94de6d94ce20725393d9c35f1c165a /pkgs/desktops
parent945758f96030ee7762ccdab32a3ffddd028b37b6 (diff)
downloadnixlib-be7b7d908f82e8ab16c43ffd0e240addd6f4018a.tar
nixlib-be7b7d908f82e8ab16c43ffd0e240addd6f4018a.tar.gz
nixlib-be7b7d908f82e8ab16c43ffd0e240addd6f4018a.tar.bz2
nixlib-be7b7d908f82e8ab16c43ffd0e240addd6f4018a.tar.lz
nixlib-be7b7d908f82e8ab16c43ffd0e240addd6f4018a.tar.xz
nixlib-be7b7d908f82e8ab16c43ffd0e240addd6f4018a.tar.zst
nixlib-be7b7d908f82e8ab16c43ffd0e240addd6f4018a.zip
Remove kdeWrapper
Diffstat (limited to 'pkgs/desktops')
-rw-r--r--pkgs/desktops/plasma-5/oxygen.nix22
1 files changed, 8 insertions, 14 deletions
diff --git a/pkgs/desktops/plasma-5/oxygen.nix b/pkgs/desktops/plasma-5/oxygen.nix
index c50fd8b05140..483d987686a5 100644
--- a/pkgs/desktops/plasma-5/oxygen.nix
+++ b/pkgs/desktops/plasma-5/oxygen.nix
@@ -1,21 +1,15 @@
 {
-  mkDerivation, kdeWrapper,
+  mkDerivation,
   extra-cmake-modules,
   frameworkintegration, kcmutils, kcompletion, kconfig, kdecoration, kguiaddons,
   ki18n, kwidgetsaddons, kservice, kwayland, kwindowsystem, qtx11extras
 }:
 
-let
-  unwrapped = mkDerivation {
-    name = "oxygen";
-    nativeBuildInputs = [ extra-cmake-modules ];
-    propagatedBuildInputs = [
-      frameworkintegration kcmutils kcompletion kconfig kdecoration kguiaddons
-      ki18n kservice kwayland kwidgetsaddons kwindowsystem qtx11extras
-    ];
-  };
-in
-kdeWrapper {
-  inherit unwrapped;
-  targets = [ "bin/oxygen-demo5" "bin/oxygen-settings5" ];
+mkDerivation {
+  name = "oxygen";
+  nativeBuildInputs = [ extra-cmake-modules ];
+  propagatedBuildInputs = [
+    frameworkintegration kcmutils kcompletion kconfig kdecoration kguiaddons
+    ki18n kservice kwayland kwidgetsaddons kwindowsystem qtx11extras
+  ];
 }