about summary refs log tree commit diff
path: root/pkgs/desktops
diff options
context:
space:
mode:
authorVladimír Čunát <vcunat@gmail.com>2017-03-07 21:59:32 +0100
committerVladimír Čunát <vcunat@gmail.com>2017-03-07 21:59:32 +0100
commitb86b7c04a30856e15391df1f5e7c901ae350fe78 (patch)
tree953fe308c0e11eed87d383c83b10e3c9cfd03989 /pkgs/desktops
parent9eb2f4cb9ea7afb8f5c623bf0d4d0e22b8e8afec (diff)
parentac0021ce53d2f9d8b26aa5374ccac1cc3e4b270d (diff)
downloadnixlib-b86b7c04a30856e15391df1f5e7c901ae350fe78.tar
nixlib-b86b7c04a30856e15391df1f5e7c901ae350fe78.tar.gz
nixlib-b86b7c04a30856e15391df1f5e7c901ae350fe78.tar.bz2
nixlib-b86b7c04a30856e15391df1f5e7c901ae350fe78.tar.lz
nixlib-b86b7c04a30856e15391df1f5e7c901ae350fe78.tar.xz
nixlib-b86b7c04a30856e15391df1f5e7c901ae350fe78.tar.zst
nixlib-b86b7c04a30856e15391df1f5e7c901ae350fe78.zip
Merge branch 'master' into staging
Diffstat (limited to 'pkgs/desktops')
-rw-r--r--pkgs/desktops/mate/default.nix2
-rw-r--r--pkgs/desktops/mate/mate-common/default.nix4
-rw-r--r--pkgs/desktops/mate/mate-desktop/default.nix33
-rw-r--r--pkgs/desktops/mate/mate-icon-theme/default.nix4
-rw-r--r--pkgs/desktops/mate/mate-terminal/default.nix36
-rw-r--r--pkgs/desktops/xfce/default.nix7
-rw-r--r--pkgs/desktops/xfce/panel-plugins/xfce4-mailwatch-plugin.nix25
-rw-r--r--pkgs/desktops/xfce/panel-plugins/xfce4-mpc-plugin.nix25
-rw-r--r--pkgs/desktops/xfce/panel-plugins/xfce4-timer-plugin.nix29
9 files changed, 159 insertions, 6 deletions
diff --git a/pkgs/desktops/mate/default.nix b/pkgs/desktops/mate/default.nix
index c3a49011c1d9..4d662cf52a99 100644
--- a/pkgs/desktops/mate/default.nix
+++ b/pkgs/desktops/mate/default.nix
@@ -1,7 +1,9 @@
 { callPackage, pkgs }:
 rec {
   mate-common = callPackage ./mate-common { };
+  mate-desktop = callPackage ./mate-desktop { };
   mate-icon-theme = callPackage ./mate-icon-theme { };
   mate-icon-theme-faenza = callPackage ./mate-icon-theme-faenza { };
+  mate-terminal = callPackage ./mate-terminal { };
   mate-themes = callPackage ./mate-themes { };
 }
diff --git a/pkgs/desktops/mate/mate-common/default.nix b/pkgs/desktops/mate/mate-common/default.nix
index 7a7ad23c6bdd..b020351afe21 100644
--- a/pkgs/desktops/mate/mate-common/default.nix
+++ b/pkgs/desktops/mate/mate-common/default.nix
@@ -3,12 +3,12 @@
 stdenv.mkDerivation rec {
   name = "mate-common-${version}";
   version = "${major-ver}.${minor-ver}";
-  major-ver = "1.16";
+  major-ver = "1.17";
   minor-ver = "0";
 
   src = fetchurl {
     url = "http://pub.mate-desktop.org/releases/${major-ver}/${name}.tar.xz";
-    sha256 = "02pj5ry3c7p5sd2mp9dsshy0ij0xgv00bxr4vvmnm027hv2silrl";
+    sha256 = "06pvbi2kk39ysd9dfi6ljkncm53hn02n7dygax6ig4p9qd750sdc";
   };
 
   meta = {
diff --git a/pkgs/desktops/mate/mate-desktop/default.nix b/pkgs/desktops/mate/mate-desktop/default.nix
new file mode 100644
index 000000000000..fcb66c9ad799
--- /dev/null
+++ b/pkgs/desktops/mate/mate-desktop/default.nix
@@ -0,0 +1,33 @@
+{ stdenv, fetchurl, pkgs, pkgconfig, wrapGAppsHook }:
+
+stdenv.mkDerivation rec {
+  name      = "mate-desktop-${version}";
+  version   = "${major-ver}.${minor-ver}";
+  major-ver = "1.17";
+  minor-ver = "2";
+
+  src = fetchurl {
+    url    = "http://pub.mate-desktop.org/releases/${major-ver}/${name}.tar.xz";
+    sha256 = "1l7aih9hvmnmddwjwyafhz87drd5vdkmjr41m7f24bn5k7abl90g";
+  };
+
+  propagatedUserEnvPkgs = [ pkgs.gnome3.gnome_themes_standard ];
+
+  buildInputs = with pkgs; [
+      intltool
+      pkgconfig
+
+      gnome3.dconf
+      gnome3.gtk
+      gnome3.defaultIconTheme
+  ];
+
+  nativeBuildInputs = [ pkgconfig wrapGAppsHook ];
+
+  meta = with stdenv.lib; {
+    description = "Library with common API for various MATE modules";
+    homepage    = "http://mate-desktop.org";
+    license     = licenses.gpl2;
+    platforms   = platforms.unix;
+  };
+}
diff --git a/pkgs/desktops/mate/mate-icon-theme/default.nix b/pkgs/desktops/mate/mate-icon-theme/default.nix
index 8acef0338715..ab699c78c0ef 100644
--- a/pkgs/desktops/mate/mate-icon-theme/default.nix
+++ b/pkgs/desktops/mate/mate-icon-theme/default.nix
@@ -3,12 +3,12 @@
 stdenv.mkDerivation rec {
   name = "mate-icon-theme-${version}";
   version = "${major-ver}.${minor-ver}";
-  major-ver = "1.16";
+  major-ver = "1.17";
   minor-ver = "0";
 
   src = fetchurl {
     url = "http://pub.mate-desktop.org/releases/${major-ver}/${name}.tar.xz";
-    sha256 = "1zldw22p1i76iss8car39pmfagpfxxlfk1fdhvr4x5r6gf36gv7d";
+    sha256 = "1kxpckaksaz5g3c4jjkh4pdm9yhbjda5835am3wg2iyy2p7rjn8n";
   };
 
   nativeBuildInputs = [ pkgconfig intltool iconnamingutils ];
diff --git a/pkgs/desktops/mate/mate-terminal/default.nix b/pkgs/desktops/mate/mate-terminal/default.nix
new file mode 100644
index 000000000000..dd380f39477a
--- /dev/null
+++ b/pkgs/desktops/mate/mate-terminal/default.nix
@@ -0,0 +1,36 @@
+{ stdenv, fetchurl, pkgs, pkgconfig, wrapGAppsHook }:
+
+stdenv.mkDerivation rec {
+  name      = "mate-terminal-${version}";
+  version   = "${major-ver}.${minor-ver}";
+  major-ver = "1.17";
+  minor-ver = "0";
+
+  src = fetchurl {
+    url    = "http://pub.mate-desktop.org/releases/${major-ver}/${name}.tar.xz";
+    sha256 = "0sbncykjf0ifj87rwpdw2ln0wavykiki4zqsw60vch7agh49fw0f";
+  };
+
+  buildInputs = with pkgs; [
+     intltool
+     pkgconfig
+     glib
+     itstool
+     libxml2
+
+     mate.mate-desktop
+
+     gnome3.vte
+     gnome3.gtk
+     gnome3.dconf
+  ];
+
+  nativeBuildInputs = [ pkgconfig wrapGAppsHook ];
+
+  meta = with stdenv.lib; {
+    description = "The MATE Terminal Emulator";
+    homepage    = "http://mate-desktop.org";
+    license     = licenses.gpl3;
+    platforms   = platforms.unix;
+  };
+}
diff --git a/pkgs/desktops/xfce/default.nix b/pkgs/desktops/xfce/default.nix
index ace5f289ab4d..36ef85aeb124 100644
--- a/pkgs/desktops/xfce/default.nix
+++ b/pkgs/desktops/xfce/default.nix
@@ -32,9 +32,9 @@ xfce_self = rec { # the lines are very long but it seems better than the even-od
   thunar          = callPackage ./core/thunar.nix { };
   thunarx-2-dev   = thunar-build; # Plugins need only the `thunarx-2` part of the package. Awaiting multiple outputs.
   thunar_volman   = callPackage ./core/thunar-volman.nix { }; # ToDo: probably inside Thunar now
-  thunar-archive-plugin 
+  thunar-archive-plugin
                   = callPackage ./thunar-plugins/archive { };
-  thunar-dropbox-plugin 
+  thunar-dropbox-plugin
                   = callPackage ./thunar-plugins/dropbox { };
   tumbler         = callPackage ./core/tumbler.nix { };
   xfce4panel      = callPackage ./core/xfce4-panel.nix { }; # ToDo: impure plugins from /run/current-system/sw/lib/xfce4
@@ -89,8 +89,11 @@ xfce_self = rec { # the lines are very long but it seems better than the even-od
   xfce4-hardware-monitor-plugin = callPackage ./panel-plugins/xfce4-hardware-monitor-plugin.nix { };
   xfce4_netload_plugin          = callPackage ./panel-plugins/xfce4-netload-plugin.nix          { };
   xfce4_notes_plugin            = callPackage ./panel-plugins/xfce4-notes-plugin.nix            { };
+  xfce4_mailwatch_plugin        = callPackage ./panel-plugins/xfce4-mailwatch-plugin.nix        { };
+  xfce4_mpc_plugin              = callPackage ./panel-plugins/xfce4-mpc-plugin.nix              { };
   xfce4-sensors-plugin          = callPackage ./panel-plugins/xfce4-sensors-plugin.nix          { };
   xfce4_systemload_plugin       = callPackage ./panel-plugins/xfce4-systemload-plugin.nix       { };
+  xfce4_timer_plugin            = callPackage ./panel-plugins/xfce4-timer-plugin.nix            { };
   xfce4_verve_plugin            = callPackage ./panel-plugins/xfce4-verve-plugin.nix            { };
   xfce4_xkb_plugin              = callPackage ./panel-plugins/xfce4-xkb-plugin.nix              { };
   xfce4_weather_plugin          = callPackage ./panel-plugins/xfce4-weather-plugin.nix          { };
diff --git a/pkgs/desktops/xfce/panel-plugins/xfce4-mailwatch-plugin.nix b/pkgs/desktops/xfce/panel-plugins/xfce4-mailwatch-plugin.nix
new file mode 100644
index 000000000000..dd80259db5fa
--- /dev/null
+++ b/pkgs/desktops/xfce/panel-plugins/xfce4-mailwatch-plugin.nix
@@ -0,0 +1,25 @@
+{ stdenv, fetchurl, pkgconfig, intltool, libxfce4util, xfce4panel, libxfce4ui,
+libxfcegui4, xfconf, gtk, exo, gnutls, libgcrypt }:
+
+with stdenv.lib;
+stdenv.mkDerivation rec {
+  p_name  = "xfce4-mailwatch-plugin";
+  ver_maj = "1.2";
+  ver_min = "0";
+
+  src = fetchurl {
+    url = "mirror://xfce/src/panel-plugins/${p_name}/${ver_maj}/${name}.tar.bz2";
+    sha256 = "1bfw3smwivr9mzdyq768biqrl4aq94zqi3xjzq6kqnd8561cqjk2";
+  };
+  name = "${p_name}-${ver_maj}.${ver_min}";
+
+  buildInputs = [ pkgconfig intltool libxfce4util libxfce4ui xfce4panel
+    libxfcegui4 xfconf gtk exo gnutls libgcrypt ];
+
+  meta = {
+    homepage = "http://goodies.xfce.org/projects/panel-plugins/${p_name}";
+    description = "Mailwatch plugin for Xfce panel";
+    platforms = platforms.linux;
+    maintainers = [ maintainers.matthiasbeyer ];
+  };
+}
diff --git a/pkgs/desktops/xfce/panel-plugins/xfce4-mpc-plugin.nix b/pkgs/desktops/xfce/panel-plugins/xfce4-mpc-plugin.nix
new file mode 100644
index 000000000000..6a2f5bd50849
--- /dev/null
+++ b/pkgs/desktops/xfce/panel-plugins/xfce4-mpc-plugin.nix
@@ -0,0 +1,25 @@
+{ stdenv, fetchurl, pkgconfig, intltool, libxfce4util, xfce4panel, libxfce4ui,
+libxfcegui4, xfconf, gtk, exo }:
+
+with stdenv.lib;
+stdenv.mkDerivation rec {
+  p_name  = "xfce4-mpc-plugin";
+  ver_maj = "0.4";
+  ver_min = "5";
+  name = "${p_name}-${ver_maj}.${ver_min}";
+
+  src = fetchurl {
+    url = "mirror://xfce/src/panel-plugins/${p_name}/${ver_maj}/${name}.tar.bz2";
+    sha256 = "1kvgq1pq7cykqdc3227dq0izad093ppfw3nfsrcp9i8mi6i5f7z7";
+  };
+
+  buildInputs = [ pkgconfig intltool libxfce4util libxfce4ui xfce4panel
+    libxfcegui4 xfconf gtk exo ];
+
+  meta = {
+    homepage = "http://goodies.xfce.org/projects/panel-plugins/${p_name}";
+    description = "MPD plugin for Xfce panel";
+    platforms = platforms.linux;
+    maintainers = [ maintainers.matthiasbeyer ];
+  };
+}
diff --git a/pkgs/desktops/xfce/panel-plugins/xfce4-timer-plugin.nix b/pkgs/desktops/xfce/panel-plugins/xfce4-timer-plugin.nix
new file mode 100644
index 000000000000..17dcb10c9d1e
--- /dev/null
+++ b/pkgs/desktops/xfce/panel-plugins/xfce4-timer-plugin.nix
@@ -0,0 +1,29 @@
+{ stdenv, fetchurl, pkgconfig, intltool, libxfce4util, xfce4panel, libxfce4ui, libxfcegui4, xfconf, gtk}:
+
+with stdenv.lib;
+stdenv.mkDerivation rec {
+  p_name  = "xfce4-timer-plugin";
+  ver_maj = "1.6";
+  ver_min = "0";
+
+  src = fetchurl {
+    url = "mirror://xfce/src/panel-plugins/${p_name}/${ver_maj}/${name}.tar.bz2";
+    sha256 = "0z46gyw3ihcd1jf0m5z1dsc790xv1cpi8mk1dagj3i4v14gx5mrr";
+  };
+  name = "${p_name}-${ver_maj}.${ver_min}";
+
+  buildInputs = [ intltool libxfce4util libxfce4ui xfce4panel libxfcegui4 xfconf
+    gtk ];
+
+  nativeBuildInputs = [ pkgconfig ];
+
+  hardeningDisable = [ "format" ];
+
+  meta = {
+    homepage = "http://goodies.xfce.org/projects/panel-plugins/${p_name}";
+    description = "Battery plugin for Xfce panel";
+    platforms = platforms.linux;
+    license = licenses.gpl2;
+    maintainers = [ maintainers.matthiasbeyer ];
+  };
+}