about summary refs log tree commit diff
path: root/pkgs/desktops
diff options
context:
space:
mode:
authorBobby Rong <rjl931189261@126.com>2024-01-02 21:41:07 +0800
committerGitHub <noreply@github.com>2024-01-02 21:41:07 +0800
commitb639f763cbe53d5fe53b69aaa696452dd2268ef4 (patch)
tree836ad8581b87f1ce8ddf748cf60befa37ba8ebd4 /pkgs/desktops
parentaf62e8e2fbe97103d67a4a40d53517eb4b2938d2 (diff)
parent142444767e5ece62b071c6f5c97a566cf38698c6 (diff)
downloadnixlib-b639f763cbe53d5fe53b69aaa696452dd2268ef4.tar
nixlib-b639f763cbe53d5fe53b69aaa696452dd2268ef4.tar.gz
nixlib-b639f763cbe53d5fe53b69aaa696452dd2268ef4.tar.bz2
nixlib-b639f763cbe53d5fe53b69aaa696452dd2268ef4.tar.lz
nixlib-b639f763cbe53d5fe53b69aaa696452dd2268ef4.tar.xz
nixlib-b639f763cbe53d5fe53b69aaa696452dd2268ef4.tar.zst
nixlib-b639f763cbe53d5fe53b69aaa696452dd2268ef4.zip
Merge pull request #277418 from OPNA2608/update/cmake-extras
lomiri.cmake-extras: unstable-2022-11-21 -> 1.7
Diffstat (limited to 'pkgs/desktops')
-rw-r--r--pkgs/desktops/lomiri/development/cmake-extras/default.nix12
1 files changed, 6 insertions, 6 deletions
diff --git a/pkgs/desktops/lomiri/development/cmake-extras/default.nix b/pkgs/desktops/lomiri/development/cmake-extras/default.nix
index ee5665cd668f..fcad286f4daf 100644
--- a/pkgs/desktops/lomiri/development/cmake-extras/default.nix
+++ b/pkgs/desktops/lomiri/development/cmake-extras/default.nix
@@ -5,21 +5,21 @@
 , qtbase
 }:
 
-stdenvNoCC.mkDerivation {
+stdenvNoCC.mkDerivation (finalAttrs: {
   pname = "cmake-extras";
-  version = "unstable-2022-11-21";
+  version = "1.7";
 
   src = fetchFromGitLab {
     owner = "ubports";
     repo = "development/core/cmake-extras";
-    rev = "99aab4514ee182cb7a94821b4b51e4d8cb9a82ef";
-    hash = "sha256-axj5QxgDrHy0HiZkfrbm22hVvSCKkWFoQC8MdQMm9tg=";
+    rev = finalAttrs.version;
+    hash = "sha256-5bLMk21pSZkuU3jAGTnjPc9ZrvVZqMUWSfFgkTtkYLw=";
   };
 
   postPatch = ''
     # We have nothing to build here, no need to depend on a C compiler
     substituteInPlace CMakeLists.txt \
-      --replace 'project(cmake-extras)' 'project(cmake-extras NONE)'
+      --replace 'project(cmake-extras' 'project(cmake-extras LANGUAGES NONE'
 
     # This is in a function that reverse dependencies use to determine where to install their files to
     substituteInPlace src/QmlPlugins/QmlPluginsConfig.cmake \
@@ -46,4 +46,4 @@ stdenvNoCC.mkDerivation {
     maintainers = teams.lomiri.members;
     platforms = platforms.all;
   };
-}
+})