about summary refs log tree commit diff
path: root/pkgs/desktops
diff options
context:
space:
mode:
authorworldofpeace <worldofpeace@protonmail.ch>2020-03-28 20:58:15 -0400
committerworldofpeace <worldofpeace@protonmail.ch>2020-04-06 02:48:07 -0400
commitb0f0003c6e2dc227fca3c4ab97464609910c51bf (patch)
tree082ae363e309534d4cc6fef3c1c9f4a84fb75d0e /pkgs/desktops
parenta1ced50fa01ba7edbab4742d12e24f1dca465c56 (diff)
downloadnixlib-b0f0003c6e2dc227fca3c4ab97464609910c51bf.tar
nixlib-b0f0003c6e2dc227fca3c4ab97464609910c51bf.tar.gz
nixlib-b0f0003c6e2dc227fca3c4ab97464609910c51bf.tar.bz2
nixlib-b0f0003c6e2dc227fca3c4ab97464609910c51bf.tar.lz
nixlib-b0f0003c6e2dc227fca3c4ab97464609910c51bf.tar.xz
nixlib-b0f0003c6e2dc227fca3c4ab97464609910c51bf.tar.zst
nixlib-b0f0003c6e2dc227fca3c4ab97464609910c51bf.zip
pantheon.elementary-notifications: init at 2020-04-04
Diffstat (limited to 'pkgs/desktops')
-rw-r--r--pkgs/desktops/pantheon/default.nix2
-rw-r--r--pkgs/desktops/pantheon/services/elementary-notifications/default.nix60
2 files changed, 62 insertions, 0 deletions
diff --git a/pkgs/desktops/pantheon/default.nix b/pkgs/desktops/pantheon/default.nix
index 2bcbbf40d948..edcda8877544 100644
--- a/pkgs/desktops/pantheon/default.nix
+++ b/pkgs/desktops/pantheon/default.nix
@@ -107,6 +107,8 @@ lib.makeScope pkgs.newScope (self: with self; {
 
   elementary-dpms-helper = callPackage ./services/elementary-dpms-helper { };
 
+  elementary-notifications = callPackage ./services/elementary-notifications { };
+
   # We're using ubuntu and elementary's patchset due to reasons
   # explained here -> https://github.com/elementary/greeter/issues/92#issuecomment-376215614
   # Take note of "I am holding off on "fixing" this bug for as long as possible."
diff --git a/pkgs/desktops/pantheon/services/elementary-notifications/default.nix b/pkgs/desktops/pantheon/services/elementary-notifications/default.nix
new file mode 100644
index 000000000000..b90f8c86bf1a
--- /dev/null
+++ b/pkgs/desktops/pantheon/services/elementary-notifications/default.nix
@@ -0,0 +1,60 @@
+{ stdenv
+, fetchFromGitHub
+, meson
+, ninja
+, pkg-config
+, vala
+, gtk3
+, glib
+, granite
+, libgee
+, libcanberra-gtk3
+, pantheon
+, python3
+, wrapGAppsHook
+}:
+
+stdenv.mkDerivation rec {
+  pname = "elementary-notifications";
+  version = "unstable-2020-03-31";
+
+  repoName = "notifications";
+
+  src = fetchFromGitHub {
+    owner = "elementary";
+    repo = repoName;
+    rev = "db552b0c3466ba1099c7737c353b7225ab1896cc";
+    sha256 = "1fhf4zx73qka935x5afv6zqsm2l37d1mjbhrbzzzz44dqwa2vp16";
+  };
+
+  nativeBuildInputs = [
+    glib # for glib-compile-schemas
+    meson
+    ninja
+    pkg-config
+    python3
+    vala
+    wrapGAppsHook
+  ];
+
+  buildInputs = [
+    glib
+    granite
+    gtk3
+    libcanberra-gtk3
+    libgee
+  ];
+
+  postPatch = ''
+    chmod +x meson/post_install.py
+    patchShebangs meson/post_install.py
+  '';
+
+  meta = with stdenv.lib; {
+    description = "GTK notification server for Pantheon";
+    homepage = "https://github.com/elementary/notifications";
+    license = licenses.gpl3Plus;
+    maintainers = pantheon.maintainers;
+    platforms = platforms.linux;
+  };
+}