about summary refs log tree commit diff
path: root/pkgs/desktops
diff options
context:
space:
mode:
authorBobby Rong <rjl931189261@126.com>2023-10-06 18:34:48 +0800
committerBobby Rong <rjl931189261@126.com>2023-10-06 18:39:10 +0800
commitad65c25dfb3acfe9526d05e5c66a15ee9cec5524 (patch)
treef88ceba79a08f167216c49a958e95f3db2f79ce0 /pkgs/desktops
parentba82dd7148e0decc2d972600cce35e2d2176a499 (diff)
downloadnixlib-ad65c25dfb3acfe9526d05e5c66a15ee9cec5524.tar
nixlib-ad65c25dfb3acfe9526d05e5c66a15ee9cec5524.tar.gz
nixlib-ad65c25dfb3acfe9526d05e5c66a15ee9cec5524.tar.bz2
nixlib-ad65c25dfb3acfe9526d05e5c66a15ee9cec5524.tar.lz
nixlib-ad65c25dfb3acfe9526d05e5c66a15ee9cec5524.tar.xz
nixlib-ad65c25dfb3acfe9526d05e5c66a15ee9cec5524.tar.zst
nixlib-ad65c25dfb3acfe9526d05e5c66a15ee9cec5524.zip
gnome.gnome-flashback: Drop --builtin
We should be able to find the session and desktop files now.
Diffstat (limited to 'pkgs/desktops')
-rw-r--r--pkgs/desktops/gnome/misc/gnome-flashback/default.nix26
1 files changed, 1 insertions, 25 deletions
diff --git a/pkgs/desktops/gnome/misc/gnome-flashback/default.nix b/pkgs/desktops/gnome/misc/gnome-flashback/default.nix
index c908dca0540b..ceb7d8d59a3d 100644
--- a/pkgs/desktops/gnome/misc/gnome-flashback/default.nix
+++ b/pkgs/desktops/gnome/misc/gnome-flashback/default.nix
@@ -23,7 +23,6 @@
 , upower
 , pam
 , wrapGAppsHook
-, makeWrapper
 , writeTextFile
 , xkeyboard_config
 , xorg
@@ -158,29 +157,6 @@ let
         };
 
       mkSessionForWm = { wmName, wmLabel, wmCommand }:
-        let
-          executable = stdenv.mkDerivation {
-            name = "gnome-flashback-${wmName}";
-
-            nativeBuildInputs = [ makeWrapper ];
-
-            dontUnpack = true;
-            dontConfigure = true;
-            dontBuild = true;
-            dontInstall = true;
-
-            # gnome-flashback and gnome-panel need to be added to XDG_DATA_DIRS so that their .desktop files can be found by gnome-session.
-            # We need to pass the --builtin flag so that gnome-session invokes gnome-session-binary instead of systemd.
-            # If systemd is used, it doesn't use the environment we set up here and so it can't find the .desktop files.
-            preFixup = ''
-              makeWrapper ${gnome-session}/bin/gnome-session $out \
-                --add-flags "--session=gnome-flashback-${wmName} --builtin" \
-                --set-default XDG_CURRENT_DESKTOP 'GNOME-Flashback:GNOME' \
-                --prefix XDG_DATA_DIRS : '${lib.makeSearchPath "share" [ gnome-flashback ]}'
-            '';
-          };
-
-        in
         writeTextFile
           {
             name = "gnome-flashback-${wmName}-xsession";
@@ -189,7 +165,7 @@ let
               [Desktop Entry]
               Name=GNOME Flashback (${wmLabel})
               Comment=This session logs you into GNOME Flashback with ${wmLabel}
-              Exec=${executable}
+              Exec=${gnome-session}/bin/gnome-session --session=gnome-flashback-${wmName}
               TryExec=${wmCommand}
               Type=Application
               DesktopNames=GNOME-Flashback;GNOME;