about summary refs log tree commit diff
path: root/pkgs/desktops
diff options
context:
space:
mode:
authorMartin Weinelt <hexa@darmstadt.ccc.de>2023-12-24 02:39:15 +0100
committerMartin Weinelt <hexa@darmstadt.ccc.de>2023-12-24 02:39:15 +0100
commita3e53d17b609a8fa1078c12cf0ce91a44c1e8293 (patch)
tree92949ac66862f7d7a763fe5512c30b3393d6febe /pkgs/desktops
parent0adafeb862faabf316c72b557eadeef46f9b148c (diff)
parent42e82652225b63f1b1008f17751599919ea124cd (diff)
downloadnixlib-a3e53d17b609a8fa1078c12cf0ce91a44c1e8293.tar
nixlib-a3e53d17b609a8fa1078c12cf0ce91a44c1e8293.tar.gz
nixlib-a3e53d17b609a8fa1078c12cf0ce91a44c1e8293.tar.bz2
nixlib-a3e53d17b609a8fa1078c12cf0ce91a44c1e8293.tar.lz
nixlib-a3e53d17b609a8fa1078c12cf0ce91a44c1e8293.tar.xz
nixlib-a3e53d17b609a8fa1078c12cf0ce91a44c1e8293.tar.zst
nixlib-a3e53d17b609a8fa1078c12cf0ce91a44c1e8293.zip
Merge remote-tracking branch 'origin/master' into staging-next
Diffstat (limited to 'pkgs/desktops')
-rw-r--r--pkgs/desktops/gnome/games/gnome-nibbles/default.nix29
1 files changed, 12 insertions, 17 deletions
diff --git a/pkgs/desktops/gnome/games/gnome-nibbles/default.nix b/pkgs/desktops/gnome/games/gnome-nibbles/default.nix
index 741006bdec19..30812f940071 100644
--- a/pkgs/desktops/gnome/games/gnome-nibbles/default.nix
+++ b/pkgs/desktops/gnome/games/gnome-nibbles/default.nix
@@ -3,30 +3,28 @@
 , fetchurl
 , pkg-config
 , gnome
-, gtk3
-, wrapGAppsHook
+, gtk4
+, wrapGAppsHook4
 , librsvg
 , gsound
-, clutter-gtk
 , gettext
 , itstool
 , vala
 , libxml2
 , libgee
-, libgnome-games-support
+, libgnome-games-support_2_0
 , meson
 , ninja
 , desktop-file-utils
-, hicolor-icon-theme
 }:
 
-stdenv.mkDerivation rec {
+stdenv.mkDerivation (finalAttrs: {
   pname = "gnome-nibbles";
-  version = "3.38.3";
+  version = "4.0.1";
 
   src = fetchurl {
-    url = "mirror://gnome/sources/gnome-nibbles/${lib.versions.majorMinor version}/${pname}-${version}.tar.xz";
-    sha256 = "l1/eHYPHsVs5Lqx6NZFhKQ/IrrdgXBHnHO4MPDJrXmE=";
+    url = "mirror://gnome/sources/gnome-nibbles/${lib.versions.majorMinor finalAttrs.version}/gnome-nibbles-${finalAttrs.version}.tar.xz";
+    sha256 = "xrG89vesx0RQAmveV7OONcJJ08K3xC2c/hH4YvPW12I=";
   };
 
   nativeBuildInputs = [
@@ -34,22 +32,19 @@ stdenv.mkDerivation rec {
     ninja
     vala
     pkg-config
-    wrapGAppsHook
+    wrapGAppsHook4
     gettext
     itstool
     libxml2
     desktop-file-utils
-    hicolor-icon-theme
   ];
 
   buildInputs = [
-    gtk3
+    gtk4
     librsvg
     gsound
-    clutter-gtk
-    gnome.adwaita-icon-theme
     libgee
-    libgnome-games-support
+    libgnome-games-support_2_0
   ];
 
   passthru = {
@@ -62,8 +57,8 @@ stdenv.mkDerivation rec {
   meta = with lib; {
     description = "Guide a worm around a maze";
     homepage = "https://wiki.gnome.org/Apps/Nibbles";
-    license = licenses.gpl2;
+    license = licenses.gpl2Plus;
     maintainers = teams.gnome.members;
     platforms = platforms.linux;
   };
-}
+})