about summary refs log tree commit diff
path: root/pkgs/desktops
diff options
context:
space:
mode:
authorJoachim F <joachifm@users.noreply.github.com>2018-10-15 21:07:01 +0000
committerGitHub <noreply@github.com>2018-10-15 21:07:01 +0000
commita2294088021a836b26be0a0916098ea0e4a02088 (patch)
tree64436ec93e0377ea169bf25cb4e53cf7f545cde0 /pkgs/desktops
parenta3d440bcb2a301ecc2326189ddb1cd1926dc18a4 (diff)
parenta8623de3071d1c9333bca483dd2a687c5c06f394 (diff)
downloadnixlib-a2294088021a836b26be0a0916098ea0e4a02088.tar
nixlib-a2294088021a836b26be0a0916098ea0e4a02088.tar.gz
nixlib-a2294088021a836b26be0a0916098ea0e4a02088.tar.bz2
nixlib-a2294088021a836b26be0a0916098ea0e4a02088.tar.lz
nixlib-a2294088021a836b26be0a0916098ea0e4a02088.tar.xz
nixlib-a2294088021a836b26be0a0916098ea0e4a02088.tar.zst
nixlib-a2294088021a836b26be0a0916098ea0e4a02088.zip
Merge pull request #48465 from romildo/upd.deepin-wm
deepin-wm: init at 1.9.32
Diffstat (limited to 'pkgs/desktops')
-rw-r--r--pkgs/desktops/deepin/deepin-wm/default.nix58
-rw-r--r--pkgs/desktops/deepin/default.nix1
2 files changed, 59 insertions, 0 deletions
diff --git a/pkgs/desktops/deepin/deepin-wm/default.nix b/pkgs/desktops/deepin/deepin-wm/default.nix
new file mode 100644
index 000000000000..f936934dcc0c
--- /dev/null
+++ b/pkgs/desktops/deepin/deepin-wm/default.nix
@@ -0,0 +1,58 @@
+{ stdenv, fetchFromGitHub, pkgconfig, intltool, libtool, vala, gnome3,
+  bamf, clutter-gtk, granite, libcanberra-gtk3, libwnck3,
+  deepin-mutter, deepin-wallpapers, deepin-desktop-schemas,
+  hicolor-icon-theme }:
+
+stdenv.mkDerivation rec {
+  name = "${pname}-${version}";
+  pname = "deepin-wm";
+  version = "1.9.32";
+
+  src = fetchFromGitHub {
+    owner = "linuxdeepin";
+    repo = pname;
+    rev = version;
+    sha256 = "02vwbkfpxcwv01vqa70pg7dm0lhm1lwhdqhk057r147a9cjb3ssc";
+  };
+
+  nativeBuildInputs = [
+    pkgconfig
+    intltool
+    libtool
+    gnome3.gnome-common
+    vala
+  ];
+
+  buildInputs = [
+    gnome3.gnome-desktop
+    gnome3.libgee
+    bamf
+    clutter-gtk
+    granite
+    libcanberra-gtk3
+    libwnck3
+    deepin-mutter
+    deepin-wallpapers
+    deepin-desktop-schemas
+    hicolor-icon-theme
+  ];
+
+  postPatch = ''
+    sed -i src/Background/BackgroundSource.vala \
+      -e 's;/usr/share/backgrounds/default_background.jpg;${deepin-wallpapers}/share/backgrounds/deepin/desktop.jpg;'
+  '';
+
+  preConfigure = ''
+    ./autogen.sh
+  '';
+
+  enableParallelBuilding = true;
+
+  meta = with stdenv.lib; {
+    description = "Deepin Window Manager";
+    homepage = https://github.com/linuxdeepin/deepin-wm;
+    license = licenses.gpl3;
+    platforms = platforms.linux;
+    maintainers = with maintainers; [ romildo ];
+  };
+}
diff --git a/pkgs/desktops/deepin/default.nix b/pkgs/desktops/deepin/default.nix
index a602d18e2095..291aa8c11be1 100644
--- a/pkgs/desktops/deepin/default.nix
+++ b/pkgs/desktops/deepin/default.nix
@@ -22,6 +22,7 @@ let
       wnck = pkgs.libwnck3;
     };
     deepin-wallpapers = callPackage ./deepin-wallpapers { };
+    deepin-wm = callPackage ./deepin-wm { };
     dtkcore = callPackage ./dtkcore { };
     dtkwm = callPackage ./dtkwm { };
     dtkwidget = callPackage ./dtkwidget { };