about summary refs log tree commit diff
path: root/pkgs/desktops
diff options
context:
space:
mode:
authorSandro <sandro.jaeckel@gmail.com>2021-01-12 01:43:30 +0100
committerGitHub <noreply@github.com>2021-01-12 01:43:30 +0100
commit805821e1cf6f8e9332969e5b040149e71556825f (patch)
tree1fbedc38e4acc407e86b49f56fbf8b66d28cf6ac /pkgs/desktops
parent8c89519c8b5af0f784253508b05d0f527f598361 (diff)
parent2c9a72d98eb92b68dabf3225e7b264cf7d77f84a (diff)
downloadnixlib-805821e1cf6f8e9332969e5b040149e71556825f.tar
nixlib-805821e1cf6f8e9332969e5b040149e71556825f.tar.gz
nixlib-805821e1cf6f8e9332969e5b040149e71556825f.tar.bz2
nixlib-805821e1cf6f8e9332969e5b040149e71556825f.tar.lz
nixlib-805821e1cf6f8e9332969e5b040149e71556825f.tar.xz
nixlib-805821e1cf6f8e9332969e5b040149e71556825f.tar.zst
nixlib-805821e1cf6f8e9332969e5b040149e71556825f.zip
Merge pull request #108714 from rhoriguchi/unite-shell
Diffstat (limited to 'pkgs/desktops')
-rw-r--r--pkgs/desktops/gnome-3/extensions/unite-shell/default.nix39
1 files changed, 39 insertions, 0 deletions
diff --git a/pkgs/desktops/gnome-3/extensions/unite-shell/default.nix b/pkgs/desktops/gnome-3/extensions/unite-shell/default.nix
new file mode 100644
index 000000000000..add87c10f1ae
--- /dev/null
+++ b/pkgs/desktops/gnome-3/extensions/unite-shell/default.nix
@@ -0,0 +1,39 @@
+{ stdenv, gnome3, fetchFromGitHub, xprop, glib, coreutils }:
+stdenv.mkDerivation rec {
+  pname = "gnome-shell-extension-unite-shell";
+  version = "44";
+
+  src = fetchFromGitHub {
+    owner = "hardpixel";
+    repo = "unite-shell";
+    rev = "v${version}";
+    sha256 = "0nqc1q2yz4xa3fdfx45w6da1wijmdwzhdrch0mqwblgbpjr4fs9g";
+  };
+
+  uuid = "unite@hardpixel.eu";
+
+  nativeBuildInputs = [ glib ];
+
+  buildInputs = [ xprop ];
+
+  buildPhase = ''
+    runHook preBuild
+    glib-compile-schemas --strict --targetdir=${uuid}/schemas/ ${uuid}/schemas
+    runHook postBuild
+  '';
+
+  installPhase = ''
+    runHook preInstall
+    mkdir -p $out/share/gnome-shell/extensions
+    cp -r ${uuid} $out/share/gnome-shell/extensions
+    runHook postInstall
+  '';
+
+  meta = with stdenv.lib; {
+    description = "Unite is a GNOME Shell extension which makes a few layout tweaks to the top panel and removes window decorations to make it look like Ubuntu Unity Shell";
+    license = licenses.gpl3Only;
+    maintainers = with maintainers; [ rhoriguchi ];
+    homepage = "https://github.com/hardpixel/unite-shell";
+    broken = versionOlder gnome3.gnome-shell.version "3.32";
+  };
+}